Announcement

Collapse
No announcement yet.

Beta 4 now available!

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I got a message to update the Mac beta, which is now out of date. On downloading and installing to my MacBook Air it just keeps telling me it is expired everytime i startup and try it.

    Comment


    • #17
      i get the prompt 3 expiered so went through all the prompts to update , looked like it did now when try to open icon in doc all i can do is get to this forum I'm stuck acdsee needs to put this up for sale, and i ll just buy it !!!

      Comment


      • #18
        Hi haemengine and photoman,

        Sorry to hear you're having trouble. Beta 3 (v4.0.289) is expired.

        Please download and install Beta 4 (v4.0.334). If for some reason the update prompt is not working properly, please download from this link (name and email required):

        https://www.acdsee.com/en/products/a...o-mac/download

        Please also ensure your local date/time is set correctly.

        If you have any issues, please post back or private message me and I'm happy to assist.

        Best regards,
        David

        Comment

        Working...
        X