Announcement

Collapse
No announcement yet.

Another Freeze on Startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Another Freeze on Startup

    My copy of ACDSee Photo Studio for Mac BETA consistently freezes on startup when launched for the first time. It then needs to be force-quit. The second time it's launched, it starts up immediately, but is only able to find the pictures created in 2016. Earlier photos are nowhere to be found. It also crashes when quitting and sends a crash report to Apple.

    Sorry, I was too optimistic about subsequent launches. After the second attempt to launch it, doing some editing and then quitting, subsequent attempts result in freezes,
    Last edited by subsea; 01-30-2017, 01:53 PM.

  • #2
    Same here. Removing the beta and all its components (at least: the ones I could find) and reinstalling does not give a solution.(In other words: The Beta does no longer start on my Mac) For a few days the beta worked OK for a beta but the more the database grew the slower the program became and now only freezes at startup.

    Comment


    • #3
      Hi subsea and fraajima,

      Thank you for your feedback. May I ask two questions?

      1. What is your environment? For example, what OS version, what hardware?
      2. Where are your images located? On a local drive, or network?

      Regards,
      David

      Comment


      • #4
        Mine froze a couple of times as well. I run on a MacBook Air



        My images are all on the local HD.

        Comment


        • #5
          One more time with the image attached..... sorry:

          Mine froze a couple of times as well. I run on a MacBook Air

          Click image for larger version

Name:	MacOS.png
Views:	1
Size:	16.5 KB
ID:	39921

          My images are all on the local HD.


          Comment


          • #6
            I have the same problem. When I load the app I get the startup screen and the whirling coloured ball forever presumably in a permanent loop! I am using MacBook Pro retina and up to date Sierra

            Comment


            • #7
              Maybe this helps? I noticed that it would not run after installation (just nothing happening), but then I thought that maybe it needed to do some housekeeping for which admin rights were needed. So I logged in with an administrator account, and then it worked. Also, when later logging out and using my normal user account, it worked.

              So the first time you run it, you need to be on an admin account! I confirmed this by installing it on another PC and it worked in exactly the same way.

              Problem "solved", but of course this needs to be addressed by the developers.

              Comment


              • #8
                I had the same experience at jorisgx, so I logged in with an admin account, opened ACDSee Photo Studio for Mac BETA, viewed a few photos on a shared folder, closed the app, switched to my normal user account, and voila - I was able to fully open and use Photo Studio. Thanks jorisgx!!

                Comment


                • #9
                  Does not work for me, as I am ALWAYS logging in as an Administrator and still get the freeze each first time ..... Have not quite figured out if it is the first time each day or what, as I am not re-installing ACDSee Photo Studio for Mac BETA and yet still get the "first time freeze" once in a while.

                  Comment


                  • #10
                    The Freeze-Up on Start-up issue has now reached a point where I can no longer start ACDSee Photo Studio for Mac BETA successfully AT ALL :-( . Initially I tried a few things to test the theory of "it freezes only the first time" and figure out which first time that would be. I.e. first time each day? First time after installation? First time ...???
                    Unfortunately, as I mentioned above, it now freezes every time and has just become a useless application for me. Later on today I might try to remove it completely from my system and re-install to see what happens then. Here are a couple of pictures from the Activity Monitor to show my situation:

                    1. I started ACDSee Photo Studio for Mac BETA.
                    2. It froze.

                    Click image for larger version

Name:	Freeze up test.png
Views:	2
Size:	64.0 KB
ID:	39951


                    3. I waited a while, but the situation did not change. Note that the CPU % is still at 99+ and the CPU time is now up to just under 6 minutes.

                    Click image for larger version

Name:	Freeze up test-2.png
Views:	1
Size:	56.7 KB
ID:	39952

                    4. After 9 minute (see picture below) and no change in the situation I Force Quit the application.


                    . Click image for larger version

Name:	Freeze up test-3.png
Views:	1
Size:	48.0 KB
ID:	39953

                    5, I restarted ACDSee Photo Studio for Mac BETA four more times. But each time it froze and I had to Force Quit it. As I said above, Later today (if I have the time) I will completely uninstall ACDSee Photo Studio for Mac BETA, then re-install it and see what happens. Stay tuned for an update.

                    BOTTOM LINE:
                    - Something else must have happened in the meantime with my ACDSee Photo Studio for Mac BETA.
                    Attached Files

                    Comment


                    • #11
                      I'm running El Capitan (10.11.6) on a 2010 MacPro. My images are located on my internal 1TB hard drive. I always log in as an adminstrator, so that's not the issue for me.

                      Comment


                      • #12
                        As "promised" in my earlier post, I completely removed every component of the ACDSee Photo Studio for Mac BETA app, then re-install it, and finally tried to run it. But unfortunately I had no success. The app simply no longer works.
                        Please let me know when there is a new BETA version which I can download. In the meantime I will no longer be able to run the app :-(

                        I could simply not believe that the app no longer works for me, even after I completely uninstalled it and re-downloaded it. But it really does not.

                        I then thought the Activity Monitor might tell me more about the issue. But unfortunately it does not. Here is what it tells me:

                        CPU Usage:
                        After twelve minutes of "not responding" the app appears to still use 99+% of the CPU. It appears at the very top of the CPU Usage list in the Activity Monitor, telling me that it is working on something. Just not clear what.

                        Click image for larger version

Name:	CPU Usage.png
Views:	1
Size:	98.2 KB
ID:	39991

                        Memory Usage:
                        The app seems to use a relatively small amount of memory (i.e. 54.7 MB) especially given that my MacBook Air has 8GB memory installed.

                        Click image for larger version

Name:	Memory Usage.png
Views:	1
Size:	126.2 KB
ID:	39992


                        Disk Usage:
                        The app seems to use practically no disk for whatever it is doing. I first thought it might be reading and sorting out all the pictures on my disk. But that does not seem to be the case. Keep in mind that the MacBook Air has a solid-state drive (not a moving disk). So the speed would be very high if the app really did work with it. But it doesn't seem to.

                        Click image for larger version

Name:	Disk Usage.png
Views:	1
Size:	128.5 KB
ID:	39993

                        Network Usage:
                        And finally I thought it might be hung on some network process. But this also does not seem to be the case.
                        Click image for larger version

Name:	Network Usage.png
Views:	1
Size:	108.5 KB
ID:	39994


                        Bottom line analysis:

                        I have a feeling it simply is circling within its logic. Some sort of a program loop.

                        Well, I guess I simply have to wait for the next version of the app so I can re-install it and do some more testing.
                        Last edited by Tahunga; 02-01-2017, 05:21 PM.

                        Comment


                        • #13
                          Hi all,

                          Thank you for these reports regarding the app freezing on startup.
                          Tahunga, thank you for the detailed info, it's very helpful.

                          I've reviewed this issue with the development team. The development team will investigate.
                          At this stage, we do not yet know the cause, however there is speculation it could be due the metadata of an image that was cataloged.

                          In the meantime, to continue using the Beta, you can manually empty your database as follows:

                          1. Close ACDSee
                          2. In Finder's menu bar, click Go and choose "Go to Folder". Type '~/Library'. Or hold down the Option key while clicking on "Go" menu and then click "Library"
                          3. Navigate to "~/Library/Application Support/ACD Systems"
                          4. Delete "ACDSeePhotoStudioBeta"
                          5. Launch ACDSee (a new, empty database will be created automatically).

                          Regards,
                          David

                          Comment


                          • #14
                            Sorry, but following this procedure didn't change anything. Still seeing a freeze prior to anything appearing on screen.

                            I installed Beta 2 and don't see any significant change in behavior. Still can't get it to launch consistently.
                            Last edited by subsea; 02-03-2017, 08:55 AM.

                            Comment


                            • #15
                              Hello David,
                              Thanks for the "step-by-step" instructions. I will try them in a minute. But since subsea says it did not work for him, I will send you a couple more pieces of information and hope this might help your developers

                              One key note: on my MacAir running MacOS Sierra your step 2. needs to be slightly modified. If you want to see "Library" appear in the "Go" menu, you need to push the shift key and not the Option key. In fact, if you hold the Option key and then click on "Go" you will see the same list as if you didn't hold the Option key. BUT, if you hold the GO menu and then push the shift key, then "Library" will appear in the list.

                              I have a really great application called AppCleaner which can remove anything and everything related to a specific app. Here is what it finds when I ask it to remove the ACDSee Photo Studio for Mac BETA app:

                              Click image for larger version

Name:	AppCleaner.png
Views:	1
Size:	360.3 KB
ID:	40044


                              Now I will delete all the files in the above list, re-install the BETA 2 version and see what happens. Note that the folder/files you mentioned in your instructions are part of the above list, and therefore will be deleted as well.

                              ..... the app just froze on the first attempt to start it up.

                              ...and one last note: I would be happy to help your development team if they have some specific questions for me, or wanted me to try some things for them.

                              Cheers,

                              Comment

                              Working...
                              X