Announcement

Collapse
No announcement yet.

Another Freeze on Startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi Subsea,

    Thank you for reporting back. I'm sorry that solution did not work.

    If I understand correctly, even after manually emptying the database, you are sometimes able to run the app, but other times it just freezes on startup, is that correct?
    Do you find that it works the first time you launch after emptying the database, but gets worse the more you use it?

    Also could you describe the freeze in more detail?

    - What do you see in the ACDSee file list? Is it completely empty? Does it show a spinning wheel? Does it show image thumbnails, or file placeholder icons?
    - If you open Activity Monitor and view the CPU tab, what is the reported "% CPU" of ACDSee?
    - In the Activity Monitor Memory tab, what is the reported "Memory" used by ACDSee? And at the bottom of the Memory tab, what is your "Physical Memory" and "Memory Used"?
    - In the CPU and Memory tabs, do you notice any other apps that might be consuming a lot of system resources?

    One last question: what is in your ~/Pictures folder? Subfolders, or files, or both? If files, what filetypes and roughly how many? If possible, are you able to change the default start folder (via the menu bar > Preferences...) to an empty local folder and restart the app?


    Regards,
    David

    Comment


    • #17
      Hi Tahunga,

      Thank you for your report.

      Is it consistently freezing when you startup after manually emptying the database? Or does it sometimes allow you to use the app?
      Previously, you provided information regarding resource usage (CPU usage was high, memory, network, and disk usage was low). In the case where it freezes on startup with Beta 2, are you seeing the same type of resource usage as before?

      One question: do you have any external or network drives mounted to your system when you launch ACDSee? If so, does the issue still occur if you unmount those drives and re-launch?

      Thank you for the info regarding the Finder menu. I tried on a MacBook Air running 10.12.4 and found the Option key did add the Library folder to the drop-down, not Shift. But I have updated the instructions since I guess it depends on individual system configuration.

      Regards,
      David

      Comment


      • #18
        Hi, David,

        The freeze occurs independently of clearing the database. Even after the database is cleared, the next attempt to start ACDsee will generally freeze. On average, the freeze occurs at least 80% of the time. When it occurs, the menu bar initially shows the normal ACDsee items but there is no window for ACDsee on the screen. Using Command-Tab will shows the ACDsee icon as if the application is active, but selecting it doesn't do anything. It's only the ACDsee application that is frozen. All other applications (and the Finder) are active. I've opened Activity Monitor for both Beta 1 and Beta 2 and never saw any extreme usage, unlike the case for Tahunga. Right now, the application is frozen (not responding) and Activity Monitor shows 0.0% CPU usage. In the Memory tab, Activity Monitor is currently showing 42.0MB (0.0MB compressed) of memory being used by ACDsee. Physical memory is 6.00GB and Memory used is 5.13GB. I'll try to get the info you've requested in your last paragraph next I successfully start ACDsee. Hope this helps.

        Mark

        Comment


        • #19
          Hello David,
          My app freezes all the time. Starting from the first time after I cleared the DB and all files as shown in my earlier post. I force quit the app a dozen times and re-started it, just to see if it made any difference. It did not. It simply freezes. In short, it NEVER lets me use the app.

          And yes, the CPU usage is still high, even with BETA 2 (and the memory, network, and disk usage is very low).

          I usually have no external drives mounted on my computer when I "play" with the app. ......except for my TimeMachine (which is used only for backups).

          And with regards to the "Option" versus "Shift" key to go to the Library. I noticed that Apple seems to have changed this several times over the last few MacOS versions. I don't even understand why they keep the Library option hidden to start with.

          I noticed that you asked Mark (subsea) "- What do you see in the ACDSee file list? Is it completely empty? Does it show a spinning wheel? Does it show image thumbnails, or file placeholder icons?"

          Here is a picture that hopefully answers those questions for my situation:

          Click image for larger version

Name:	App window.png
Views:	1
Size:	169.6 KB
ID:	40072

          In this particular test I did have a small, mobile hard drive attached, as I was running a job using iTunes, and that small drive contains my iTune libraries .... nothing more, nothing less

          ....and by the way, the ACDSee Photo Studio for Mac BETA app ALWAYS opens with this window, highlighting the "Pictures" folder. And since it is frozen immediately, I can't open any of the folders, or even change the size of the window.

          Hope this helps.

          Comment


          • #20
            David,

            I was able to restart Beta 2 this morning. Here's the window that opened, showing the contents of the Pictures folder.

            Screen Shot 2017-02-04 at 11.11.30 AM.pdf

            I changed the start folder to an empty desktop folder and quit Beta 2. I attempted to restart Beta 2 and it froze again. Note, as I mentioned, when it freezes, the menu bar shows up as shown in the image, but the window you see here doesn't show up and all you see is whatever is behind what should be here. This can be another application if one is open, or the desktop if an application is not open.

            Mark
            Attached Files
            Last edited by subsea; 02-04-2017, 08:32 AM.

            Comment


            • #21
              Hi subsea,

              Thank you for getting back to me with this information.
              My theory is that your issue is separate from Tahunga's.

              I've investigated your issue and I think I may know the cause.

              As you mentioned, when you quit ACDSee, it crashes. This is a known issue on 10.11 El Capitan and will be fixed very soon.
              I can reproduce your issue if I quit ACDSee and then launch again right away. But I notice if I wait, then re-launch, it opens as expected.

              Could you try this and see if it resolves your issue?

              Also, I've found that if you quit the app via Cmd-Q or via the app menu bar, then it crashes. However, quitting via clicking the red circle in the title bar doesn't trigger the crash.

              The crash is obviously incorrect behaviour and will be fixed very soon. But these workarounds may help in the meantime.


              Best regards,
              David

              Comment


              • #22
                Hi, David,

                As you noted, if you click the red button in the title bar, the crash on quit doesn't occur. Note that having the application quit when the red button is clicked is not standard behavior on a Mac. Normally, clicking on that button results in the open window closing, but the application remains open. I also saw that clicking the red button to quit the application enables the application to be restarted without problem. That would imply that the crash on exit is the source of the problem, since the inability to restart seems to occur only after a crash on exit..

                That being said, it's more complicated than that. If you start up in safe-boot mode (i.e. hold down the shift key while restarting the computer), ACDSee restarts without a problem even though pressing CMD-Q or using the menu command to quit does trigger the crash on quit. That probably means that, under normal start-up conditions, the crash on exit interacts with something that's loaded into memory that isn't present in safe-boot mode.

                Also, I haven't noticed a consistent link between the length of time between attempts to start ACDSee and the ability to restart it. I suspect that the time it takes before it can be restarted successfully is linked to how long it takes for something to be overwritten or drop out of a cache. I have no idea which one.

                Hope this helps.

                Mark
                Last edited by subsea; 02-08-2017, 01:40 PM.

                Comment


                • #23
                  Hi Tahunga,

                  Thank you for reporting back. The developers are working on a fix for this issue.

                  Two final questions:
                  1. Is your "MobileBackups" folder always mounted to your filesystem when you launch ACDSee? Are you using an AirPort Time Capsule?
                  2. Are there any unusual files in your Pictures folder? For example, symlinks, hidden files, socket files, etc.

                  Thank you,
                  David

                  Comment


                  • #24
                    Hi David,

                    My response to your recent questions timed out in the "Forum system". Luckily I had copied my answer, but can't find the actual place where your questions were. So I am simply attaching the here:

                    Here are my answers to your questions:
                      1. The "MobileBackups" has only been attached to this computer ONCE. I tested a remote disk to run Time Capsule backups when I am "on the road". I have no idea why it shows up in ACDSee. It does not show up anywhere else in the Finder or on my Mac.
                      2. Yes, I am using an AirPort Time Capsule to backup my Mac Air. Always have, always will.
                    1. I would expect some "unusual files" on my computer, but not necessarily in my Picture folder. Here is what my Finder shows in my "Picture Folder". And I would expect that Aperture, for example, has hidden files. But I don't know for sure. Never checked.
                    Here is a picture of my Picture Folder: Click image for larger version

Name:	Picture Folder.jpg
Views:	1
Size:	179.3 KB
ID:	40278

                    I don't know which app created the (Originals) folder ... so I don't know what the xmp files are all about.

                    The Adobe, Aimersoft Video Converter Ultimate, and iSkysoft iMedia Converter Deluxe folder are empty. The Aperture Slideshows folder has one .mov file in it. The HDR Sample Brackets (4) contains four .zip files. The Sreensaver folder contains about 1000 pix in JPG and PNG format. And the Test Pictures folder contains one tiff and one PEF (Pentax Raw format) picture.

                    Comment


                    • #25
                      Hi, I'm using Beta version 4.0.262 which looks promising and fixed several problems I'd had with Pro3, although various issues to report (will post individual threads).

                      I also had the crash and freeze on startup after cmd-Q (while generating thumbnails). Deleted/re-installed lots but needed to delete files in Library, User Library and /var/ before it would work again (seen this already registered in detailed post by Tahunga - thanks!)


                      FYI, I still got a crash and error report on cmd-q from view mode the only other time I've tried cmd-q, but it restarted fine.

                      System info:

                      MacBook Pro (Retina, 13-inch, Late 2013), 2.8 GHz Intel Core i7, 16 GB 1600 MHz DDR3, Intel Iris 1536 MB
                      OS-X El Capitan 10.11.6 (15G1217)
                      Images all stored on internal SSD
                      No other significant programs running (Messages, Notes, 2-4finder windows open, command prompt)

                      Cheers, keep up the good work
                      Baz

                      Comment


                      • #26
                        Hi Tahunga,

                        Thank you for your reply.

                        I've tried to replicate your setup, but I can't reproduce the issue. However we will add improvements to detection of volumes in a future BETA which should address these issues.

                        Based on your comment and screenshot, I don't think there is anything "unusual" in your Pictures folder.
                        The [Originals] folder is created by ACDSee. It looks like you previously had those 2 JPEGs in your ~/Pictures folder and Developed them using ACDSee, but then moved or deleted those files using Finder or any app other than ACDSee (which is why the [Originals] folder remains).

                        Regards,
                        David

                        Comment


                        • #27
                          Originally posted by fraaijma View Post
                          Same here. Removing the beta and all its components (at least: the ones I could find) and reinstalling does not give a solution.(In other words: The Beta does no longer start on my Mac) For a few days the beta worked OK for a beta but the more the database grew the slower the program became and now only freezes at startup.
                          This is exactly one of the big problems that hounded V1 through V3. There are serious memory problems still with this new rewrite. The memory cashe never clears and the program slows and slows with usage and as more images added. I remember long ago during the V3 Beta people telling ACD how to fix it but it never happened. So here we are. No other similar Mac app has this problem and none of the ACD Windows versions either. Something is seriously wrong in the architecture.

                          Comment


                          • #28
                            The latest version still freezes. It always freezes on the first launch after restarting the Mac and freezes at launch randomly thereafter.

                            Comment


                            • #29
                              Hello, have you tried a complete uninstall and reinstall. Please try these instructions:

                              Instructions to remove supporting files/folders of ACDSee Photo Studio for Mac BETA: NOTE: This will remove the database file. Step 1: Remove ACDSee Photo Studio

                              Comment


                              • #30
                                I've tried uninstalling and reinstalling with each version and it hasn't helped, so far. I'll try it again, but I'm not optimistic. I'll let you know.

                                OK, I uninstalled and reinstalled as directed and had 2 freezes already.
                                Last edited by subsea; 03-10-2017, 02:45 PM.

                                Comment

                                Working...
                                X