Announcement

Collapse
No announcement yet.

BETA 8 no longer works as an External Editor for Aperture

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BETA 8 no longer works as an External Editor for Aperture

    The past few BETA versions worked fine as "External Photo Editors" in Aperture. But BETA 8 no longer does. I have redefined ACDSee BETA 8 as the "External Photo Editors" in Aperture, selected a JPG image, and then clicked on Photos>Edit with ACDSee Beta... ACDSee opens, but only with the main screen, and not with the actual picture I selected (as the previous BETA Versions did).

    In desperation, I re-selected the same picture in Aperture and then went to the Aperture menu Photos>Edit with ACDSee Beta once again.. This time ACDSee switched its screen to VIEW of the picture selected in Aperture. It also duplicated the image in the Aperture library as a PSD format picture. But it was not possible to move to the "Develop" screen in ACDSee as was possible in the previous BETA Versions.

    .....In short, what worked well in previous BETA versions no longer does.

    Hope you can bring this feature back soon, as it is key to me as I keep all my pictures in Aperture Libraries and edit them using, sometimes, external editing software.

  • #2
    I just did some extensive testing regarding the "External Editor for Aperture" feature, which used to work well under pre-8 BETAs.

    Here is step-by-step what happens. Note: Since I still can not upload sample pix using this Bug Reporter, I am attaching Dropbox Links:

    1. I select a small JPG picture in the Aperture Browser https://www.dropbox.com/s/qs13jbk8tx...See-1.jpg?dl=0

    2, Next I select ApertureMenu>Photo>Edit with ACDSee Beta.... https://www.dropbox.com/s/7dgf0u2ji8...See-2.jpg?dl=0

    3. ACDSee Beta opens in View Mode, but the ICON in the filmstrip does not show an image https://www.dropbox.com/s/hi2gdmtxcl...See-3.jpg?dl=0

    4. When I click on the "Develop" link in the right upper corner of the ACDSee window, the display switches to a completely different picture https://www.dropbox.com/s/qmlxcw2m63...See-4.jpg?dl=0
    In fact, the shown image is picture in my Picture Folder. https://www.dropbox.com/s/7dsrr8a5th...See-5.jpg?dl=0

    5. At this point in the process when I go back into Aperture I notice that ACDSee created a PSD duplicate of the picture I initially selected. This PSD image used to be the picture which ACDSee would use to apply the edits I made: https://www.dropbox.com/s/9mwyjtezrj...See-6.jpg?dl=0

    6. The original JPG picture would remain in the Aperture Library, completely unharmed (as it should be): https://www.dropbox.com/s/mpbu0q9ux6...See-7.jpg?dl=0

    I finally closed ACDSee and tried to repeat steps 1. and 2. above. This time ACDSee opened and showed an "Import" view with pictures kept on my nearby iPad. No idea why it did this, but in my view, ACDSee can no longer be used as an external Editor to Aperture https://www.dropbox.com/s/pmgzwnotsl...See-8.jpg?dl=0

    As I mentioned, ACDSee did work as an external Editor in Aperture in earlier BETA versions. However, if this is not possible any longer, could ACDSee be adjusted so that it can work as an Aperture Plug-in ???? That would be just as nice for me.

    Comment


    • #3
      Hi Tahunga,

      Thank you for your helpful feedback.

      I'm able to reproduce the issues you've identified. That is:
      - the filmstrip does not show thumbnails when using ACDSee as an external editor
      - it's not possible to move to the "Develop" screen in ACDSee with the opened image selected.

      I've logged these issues in our internal bug tracking system and discussed with the product team.

      Regarding the Import dialog appearing on launch, you can disable this behaviour by going to Preferences > General > Camera, and unchecking "Show import dialog when a camera is connected".

      Best regards,
      ​David

      Comment


      • #4
        Hi David,
        thanks for the helpful feedback. I am now looking forward to BETA 9 which hopefully will fix the above issues.

        In the meantime I need to go through all the ACDSee Preferences and adjust them. As you quite clearly state, my "Import Dialog" issue was a "lack of user knowledge" issue. It's now fixed

        Comment

        Working...
        X