Announcement

Collapse
No announcement yet.

Canvas Draw and Intuos graphics tablet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Canvas Draw and Intuos graphics tablet

    Unfortunately, I do not get to use my copy of Canvas Draw 4 as often as I would like, but recently I noticed an issue with the software. I opened a Canvas file from work (.cvx) and attempted to look at the list of objects in the document. Interestingly, when I click on the docked Document Layout palette nothing happens. I know a single click is registering because I can drag the tab, but the palette does not pop up as it should. This problem seems to only occur when I am using my Intuos graphics tablet; using a mouse, clicking on a palette tab opens the palette as expected. For any other operation in Canvas Draw (e.g., selecting objects, selecting tools, etc.) else a single tap of the pen registers as a single click, as it should, but the click on a palette tab does nothing.

    The weird thing is that I did not have this problem previously. I purchased the graphics tablet in March, Canvas Draw 3 about a month later, and then upgraded to Canvas Draw 4 shortly after it became available this past summer. Once I got the graphics tablet, I ceased using a mouse, as I prefer to use the tablet as my primary input device, so I had never used a mouse with Canvas Draw. I also tried opening files that I created in Canvas Draw 4 and the problem persists, so I know it is not associated with the Canvas X file from work.

    Has anyone else had issues with graphics tablets?

  • #2
    Make sure you have the latest driver for your Intuos tablet. Visit http://www.wacom.com/en-us/support/p...upport/drivers where you can download the newest driver for your OS.

    Comment


    • #3
      My tablet drivers are up to date (6.3.27-2). In fact, I was wondering if one of the interim updates since the last time I used Canvas Draw caused the problem.

      Comment


      • #4
        You might clear any plist or Saved State folders for the tablet. And of course try reinstalling the driver/software.

        Comment


        • #5
          Purging and reinstalling the tablet drivers was a no go.

          This is really annoying. If the graphics tablet simply did not work with Canvas Draw, then it would be a clear incompatibility issue, albeit a strange one as it is just another type of input device. The fact that a pen click properly registers as a (left) mouse click in every other aspect in Canvas Draw 4 except opening a docked palette makes me think that there is a bigger issue at play. While I can still get to palettes through the Window menu, doing so defeats the purpose of having the ability to dock those palettes that I typically use.

          I have used various Wacom tablets on my home computers since my Power Mac G4 Cube (ca. 2000) as my primary input device. Until now, I have never had any issues with any software on any of my Macs excepting perhaps the fact that various versions of Canvas through the years have had varying degrees of compatibility/incompatibility with the pressure sensitivity or eraser features of the pro-level Wacom pens. (As I do more illustration/technical drawing/page layout work than “painting” in Canvas, that has never been a real issue for me, but I can imagine that it would be problematic for people used to having those capabilities when they use products such as Photoshop.)

          Aside from this particular matter, hopefully ACD Systems will look into providing and maintaining Photoshop-level compatibility with graphics tablets in Canvas (Canvas X and Canvas Draw) in future releases.

          Comment


          • #6
            Have you sent ACD support a ticket on this? https://acdsystems.desk.com/customer...tal/emails/new

            Comment


            • #7
              I use an Intuos 4M all the time and I have no problems with Canvas Draw 4 and docked pallettes...
              Mac OS 10.11.6

              Comment


              • #8
                I just sent an e-mail to ACD support.

                Comment

                Working...
                X