Announcement

Collapse
No announcement yet.

Can't set Document scale

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't set Document scale

    I'm using Canvas Draw 5.0.1 on OSX 10.14.1 and I want to set the scale on a document. The instruction say "Choose Layout | Rulers." ... "Define the drawing scale in the Document scale section." However, the Document scale section of the Rulers dialog box is greyed out - I can't make any changes. I can set different units (inches, feet, cm, etc) in the section above this, but I want 1.5 document inches to display as 19 feet - there is no way to enter this scale. Is there something I am missing that unlocks the Document scale section of the Rulers dialog box? I can modify units in the "Define Units" dialog, but I'm wondering why the Document scale is inaccessible.

    Early days, but Canvas Draw is behaving well on 10.14.1.

  • #2
    My method is to draw a line 1.5" long, go to Layout > Document Scale > Set Document Scale. In the popup menu I set the 1.5" page distance to equal a 19' world distance. There may well be other methods, but mine is easy for me to remember.

    Tim

    Click image for larger version

Name:	Scale.jpg
Views:	2
Size:	23.5 KB
ID:	47990
    Attached Files

    Comment


    • #3
      I like that Tim, it will help me for sure. Thanks.

      Comment


      • #4
        I tried your method to set document scale, but it is unselectable.
        Last edited by KD4KO; 11-29-2018, 06:28 AM.

        Comment


        • #5
          Hey, me too in Canvas 4.

          Click image for larger version

Name:	z scale grey.png
Views:	1
Size:	70.8 KB
ID:	47999

          Comment


          • #6
            I have no idea why document scale is grayed out. It is not that way for me either with a line selected or not. I just checked and found that you can set the scale by going to preferences > measurements > ruler and then set page distance and world distance there. To have the dimensions in the document read as you wish (feet instead of inches, for example), select the document units at the top of the ruler menu to what you want.

            Tim

            Comment


            • #7
              Like KD4KO and Mike, the "Set Document Scale..." is greyed out, whether I select the line or not. And Tim, as in my original post, preferences > measurements > ruler has the Document Scale section also greyed out (this preference is also available from Layout > Rules). I guess something isn't right with some copies of Canvas, but ok with yours! As I wrote, it can be set in preferences > measurements > define units, but I do believe its meant to work the way you - and the manual - have described it. I'll file a bug report.

              Comment


              • #8
                Ha! RTFM indeed, although this was far from obvious. The solution explains why it works for Tim but not others. When writing it up as a bug, I was directed to a help article before submitting that addressed this:
                Change of the Drawing Scale is only available in the illustration Document. If your document type is of Publication, Drawing Scale feature will not be activated.
                To change the document type, please click Layout | Document Setup.. and then choose Illustration as the Type of the Document
                .
                Indeed, mine was set to Publication, and changing to Illustration enabled Document scaling via the Layout menu or the Preference dialogs. I have no idea why this limitation is applied - makes no sense to me.

                Comment


                • #9
                  I actually just discovered that myself before I read this and was about to post it.

                  Comment


                  • #10
                    And that answers why it works for me. I almost always work in Illustration mode and, if at all, switch to Publication after completing most of what I want to do. I accidentally make things easy for myself!

                    Tim

                    Comment

                    Working...
                    X