Announcement

Collapse
No announcement yet.

angle dimensioning tool not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • angle dimensioning tool not working

    Problem: the angle dimensioning tool works only intermittently. I can rarely get it to display the purple circles and get it to enter the angle. I am trying to use it in a technical drawing that I have created, but it will not work (i.e. measure and display the acute angle between two line segments). But when I start a new illustration, place two crossed lines on the page, the tool works. Any ideas on how to make it work reliably?

    Thanks.

  • #2
    Hi,
    I just followed the procedure you described i.e. drew two crossing lines and measured the angle between them. I use both Canvas 11 and Canvas X 16 GIS under Windows 10 x64 on a Dell m4800. I tried it on both versions and the angle measurement worked fine.
    Last edited by Paul Maconochie; 08-11-2016, 07:09 PM.

    Comment


    • #3
      My results on Canvas X 16 64 bit running in Windows 7 are the same as Paul Maconochie , but you were successful drawing two arbitrary lines as we did. The issue must relate to your illustration.

      Comment


      • #4
        rsengebusch! Are You Sure You are on the right layer? I Think You have to be on the layer that contain the objects you will measure. I just tested here on CVX 17 GIS and angle tool works, but if i go to a layer above the lines it will not automatically show the purple dot along object sides or lines. Itask You to select the first line. SO ither You have to go to the correct layer (where the lines or objects you will measure are) or check the Select across layers tick-box in the Properties bar.

        Comment


        • #5
          Any of you ever get this angle dimension tool thing worked out. Just bought Canvas X17 and if I try to dimension an angle on a new sheet it seems to work fine, but when I import a Canvas 11 file into 17 it doesn't work at all When clicking on the lines, it doesn't seem to recognize them. I'm am using only one layer so the layer thing is out. I have no locked layers and the lines are at the front of the drawing. Running on a 64 bit Windows 10 platform. Plenty of processor and 32 Gb of ram. Anybody else having this issue? Thanks

          Comment


          • #6
            Can either of you upload a culprit file? Us testing with two lines in a new file seems pointless in tracking your problem.

            Comment


            • #7
              Hmm the plot thickens. Since I posted my reply (8 December 2016) in which I could measure the angle between two lines in Canvas 11 and Canvas 16, I have upgraded to Canvas17 GIS and removed Canvas 16. In response to the ongoing discussion I repeated the experiment and have reproduced the problem of being unable to measure the angle between lines in Canvas 17 GIS.

              In Canvas 11 the angle measurement between lines works fine with the same .cvx file that I have attached but does not work for me in Canvas 17 GIS.

              I have attached the file for your interest.

              Time for a bug report to ACD Systems.
              Attached Files

              Comment


              • #8
                A solution to the angle dimension tool problem

                I turned off snap to grids and snap guides and the angle measurement tool worked.
                I turned on snap to guides and the angle tool worked
                I turned on snap to guides and snap to grids and the tool did not work.
                Conclusion - turn off snap to grids

                Next I went to File>Configuration>Grids and Guides
                Unchecking the Snap to X and Snap to Y resulted in the angle measurement tool working
                Conclusion - in configuration of grids and guides uncheck Snap to X and Snap to Y is another method to achieve the same effect of turning off snap to grids but is likely to remain set in that configuration.

                I also checked in Canvas 11 and observed the same behaviour i.e. angle dimension tool would not work when snap to grids was turned on.
                Last edited by Paul Maconochie; 04-12-2017, 01:10 PM. Reason: 13-Apr-17 Made a correction and added clarificaiton.

                Comment


                • #9
                  I yet to confirm your findings but wanted to mention that for as long as I can recall Snap to Grids has always interfered with SmartMouse snapping. Through the past several versions I find I have to turn off Snap to Grids for SmartMouse to even work. Best I can guess is that the angle dimension tool uses the same code snippet as SmartMouse. In fact, I just invoked the angle dimension tool and the SmartMouse On tick box is ticked and grayed out in its palette...

                  Another tidbit is in Canvas 17 (and IIRC Canvas 16) there is a toggle on/off button next to display/hide "Grids" in the Property Bar when the Select tool is invoked and nothing is selected. A custom placed toolbar button functions the same, but it doesn't gray out when Snap to Grids is off like the Property Bar button.

                  Comment


                  • #10
                    Paul / Joe,
                    Tried turning off snap to grids on Canvas 17 with a file that wouldn't measure angles at all and now it works fine now. Didn't need to turn off smart mouse snap option in Windows 10 with Microsoft 5050 wireless keyboard/mouse. Didn't really like the snap thing. Things are good. Thanks for the feedback.

                    Comment


                    • #11
                      Originally posted by cegsteve View Post
                      ... Didn't need to turn off smart mouse snap option...
                      No one said anything about turning off SmartMouse. I apologize if my post was misleading.

                      Comment

                      Working...
                      X