Announcement

Collapse
No announcement yet.

Batch processing loses selections

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Batch processing loses selections

    This is a relatively minor issue and I am only reporting it because it may have some related side effects that are more serious and it probably does not hurt to have it on record.

    I process images by going through all of the images in a folder, rating the ones I want (Cmd-1 or Cmd-2) to keep and then, in the Manage Mode, I choose the rating I want (usually 1 star), select all of the images and run a batch file to convert them to jpgs and move them to a separate folder.

    The process works properly and I get the raw images converted to jpgs (or tiffs if I want to process them in a pixel editor), but as the batch file processes the images it first converts the raw image to jpg and then moves the jpgs to the destination folder. Adding each new jpg file to the original folder causes the new jpg to show up momentarily in the Manage mode and then disappear when the file is moved. All of that is correct and expected, but as the new files are added to the folder the selection list changes and at the end of the processing not all of the originally selected images are still selected. This sometimes leads to the conclusion that perhaps I did not select all of the images originally.

    Here is a screen shot of the selected images before the batch:

    Click image for larger version

Name:	Pro4BeforeBatch.jpg
Views:	1
Size:	196.0 KB
ID:	44911

    Here is a screen shot of the selected images after the batch:

    Click image for larger version

Name:	Pro4AfterBatch.jpg
Views:	1
Size:	184.0 KB
ID:	44912

    As you can see, some of the images that were selected before the batch are no longer selected after the batch.

    My batch file is simple and consists of two instructions - first, convert the images to jpg and second, move them to a specified folder.
Working...
X