Announcement

Collapse
No announcement yet.

Picture Icon does not refresh after editing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Picture Icon does not refresh after editing

    Here is a new issue for me. I edited one of my JPG pictures using Snapheal CK (a tool to remove things from the picture using some logic). But since I saved the updated picture, the related icon no longer shows the picture. It only shows the ACDSee "Snail". How come?

    ....as I still can't upload regular JPG files using this bug reporter, here are the links to see my pictures in Dropbox:

    The first image shows the missing icon picture in the Development View:
    https://www.dropbox.com/s/sqpi7k9jjw...velop.jpg?dl=0

    The second image shows the missing icon picture in the Manage View:
    https://www.dropbox.com/s/4j2kve19ce...anage.jpg?dl=0

    And the third image shows the missing icon picture in the List view:
    https://www.dropbox.com/s/7nnfrkdrga..._List.jpg?dl=0



    I would think it should be possible to "refresh/re-build" the icon......but I have not found how to do this.

    Thanks for any help you might be able to provide.

  • #2
    For what it is worth -

    I tried this, using a jpg and Tonality (I do not have a working copy of SnapHeal) and, when I exported the image back to the original, Photo Studio did update the thumbnail in Manage Mode properly, so perhaps the issue is system related.

    Have you tried saving the jpg from SnapHeal as a differently named file in the same folder? When I had the same problem you are having with Dxo's PhotoLab I started adding the letter 'A' to the end of the file name and that solved that problem. The same thing does work in Photo Studio (I tried it) and it might be helpful to know if you get the same "snail" icon if you try a different file name.

    Comment


    • #3
      Hi miksons,
      First of all: Yesterday, after using SnapHeal to edit the picture in question, I closed and opened Photo Studio several times .... the "snail" icon stayed. Then today (after closing down the computer and re-starting it this morning) the icon was obviously refreshed and showed the edited picture.

      Second: I tried your suggestion of renaming the image after editing with SnapHeal ..... but that made the problem worse. Initially the edited and renamed copy of the image showed up just like yesterday with the "snail" icon. Both in the VIEW view:
      https://www.dropbox.com/s/hpsno533vl...-View.jpg?dl=0

      ..and in the MANAGE view:
      https://www.dropbox.com/s/q8cx5s5b75...anage.jpg?dl=0

      After restarting Photo Studio, the edited picture no longer showed up in any view!!! Although it definitively is in the Library. Here is a picture with the re-named picture as seen in the Finder:
      https://www.dropbox.com/s/qdhkycn4y1...inder.jpg?dl=0

      One thought: SnapHeal saves JPGs as JPEGs. It should not make any difference ..... but it just might.

      Comment


      • #4
        .....and one more test: I just thought it might be the picture format which caused the problem. So I changed the picture to a different format (PNG). But now I have two "Snail" icons:
        https://www.dropbox.com/s/zvtxhxt05o...20PNG.jpg?dl=0

        And this is true when I look in the Manage View:
        https://www.dropbox.com/s/hd6eipitgl...ormat.jpg?dl=0

        Strange, to say the least.

        Comment


        • #5
          Originally posted by Tahunga View Post
          One thought: SnapHeal saves JPGs as JPEGs. It should not make any difference ..... but it just might.
          Tonality does the same, but I routinely change the suffix to jpg in the save dialog box so I wonder if that might be the reason. I am going to try that now.

          No. That did not make any difference. I used the export functionality (I am assuming you are doing the same) and saved using both jpeg and jpg. Tonality is at the B&W tool so it is easy to see the results, and both showed up in Manage Mode. I have only the trial version of SnapHeal so I can not actually export the final image to test what happens.

          I have now tried starting with a raw and starting with a jpg, saving as jpg and jpeg and using both Manage and View modes, and have not seem the problem you are seeing. What OS are you using?

          Comment


          • #6
            Here is my setup:

            MacBookAir: macOS High Sierra, Version 10.13.4 Beta (17E150g)
            ACDSee Photo Studio Version 4.1.674
            SnapHeal CK (Creative Kit) Version 1.7 (1200)

            Now that I have rebooted my mac, the results are:

            1. The original picture, which incidentally came from an original RAW picture but was changed to a JPG when I edited it using ACDSee Photo Studio, is visible, including a valid icon in the MANAGE, VIEW, and DEVELOP Views.

            2. The picture I edited with SnapHeal (Via Photo Studio>View>Open With>SnapHeal) see the link .....

            https://www.dropbox.com/s/exptrm6nvu...pHeal.jpg?dl=0

            .....is clearly visible in all Photo Studio views, except the icon is ALWAYS just the ACDSee "Snail"

            3. The PNG copy of the picture I created using Photo Studio is also visible in all Photo Studio views, except the icon is ALWAYS just the ACDSee "Snail". In short, it shows up the same way as the picture edited using SnapHeal.

            4. In the Finder, all three pictures are visible as they should be. And looking at them using PREVIEW shows them just as they should.

            https://www.dropbox.com/s/7ce4wnwp0q...0view.jpg?dl=0

            I still believe there is something wrong within ACDSee Photo Studio.

            Comment


            • #7
              Originally posted by Tahunga View Post
              I still believe there is something wrong within ACDSee Photo Studio.
              I do not question what you are reporting. I am only wondering why I am not seeing the same thing. There has to be some difference that is causing the issue you are seeing.

              I am running on a Mac Mini, with High Sierra 10.13.3.
              Tonality 1.4.0
              ACDSee 4.1.674

              I wonder if it could be a difference between SnapHeal and Tonality. I am going to try using some other MacPhun apps that I have to see if anything reproduces the same results as you are seeing.

              Comment


              • #8
                An update.

                I only have licenses for 3 Creative Kit apps - Intensify, Noiseless and Tonality - as they are the only ones I would actually use. I do not have SnapHeal, although it seems to do a decent job, because I do the same thing using Affinity Photo. In any case I made sure my licensed apps were up to date and I then tried sending a raw image to each of them from the Manage Mode of ACDSee Photo Studio. Once they were opened in Photo Studio I made some change and exported them as jpgs (I did change the name to jpg in the app dialog boxes).

                All of the updated images showed up properly in my copy of Photo Studio. I never got the snail thumbnails that you are seeing, so something on your system (or something on mine) is making a difference.

                You are on the High Sierra Beta and I am not, but I have no idea if that is relevant.

                If you have any other Creative Kit apps you might want to try them to see if the issue exists with all of them or only SnapHeal.
                Last edited by miksons; 02-27-2018, 03:24 PM.

                Comment


                • #9
                  OK. I have sort of reproduced your issue with SanpHeal (I bought a copy today as it was on sale) and found that when I remove an object from an image and save it back as the same image (jpg -> jpg) using the jpg suffix (not jpeg) the thumbnail does not update. However I have not seen the "snail" icon.

                  Now that I have seen how to reproduce this issue I will test using some other apps to see if the problem is general in nature.

                  Comment


                  • #10
                    Thanks for all your effort to try and figure out what's going on. Unfortunately I have also some additional test results which do not add clarity to the problem

                    I figured I would stay away from SnapHeal for my next tests. Instead I moved a RAW image (IMGP3365.PEF) into the Screensaver folder. Note that PEF is the RAW extension for Pentax RAW pictures. I then opened ACDSee Photo Studio. The IMGP3365.PEF picture is visible in MANAGE, VIEW, and DEVELOP view. BUT, although the image is shown correctly, the thumbprint is shown with the "snail" in all views.

                    Here it is in MANAGE View https://www.dropbox.com/s/e9972s6we7...ANAGE.jpg?dl=0

                    ...and here it is in the VIEW view https://www.dropbox.com/s/1e8ptkd8pp...0VIEW.jpg?dl=0

                    In short, my thumbprints don't seem to update themselves. Do you know if there is a command to "refresh" the thumbprints? My primary picture editor and library manager is good old Aperture. And Aperture has a "refresh" and even a "re-create" for thumbprints.

                    Comment


                    • #11
                      > my thumbprints don't seem to update themselves

                      As I mentioned, I have been able to reproduce this issue in Manage Mode using SnapHeal, although I did not get the "snail", only found that the thumbnail did not update after file modification. However changing folders and then changing back forced the update.

                      One question. What are your thumbnail settings in Preferences? Have you changed any of them?

                      > Do you know if there is a command to "refresh" the thumbprints?

                      No, but changing folders and then changing back does seem to force that. It is not a reasonable workaround because you would have to do it for every image, but if you are externally editing only a few it might help until they get this fixed (assuming they do). Dxo's PhotoLab has this problem and has told me they will not fix it as they do not want people using an external editor and then returning the image back to their tool.

                      > Do you know if there is a command to "refresh" the thumbprints?

                      Yes. And if Aperture was being supported I might still be using it ...




                      Comment


                      • #12
                        Sorry, but I don't quite understand what you mean when you say "changing folders and then changing back". Can you please clarify?
                        Thanks

                        Comment


                        • #13
                          Sure.

                          In Manage Mode, on the left side of the screen, is the list of folders that you select from when you want to work on images. On my copy they are Favorites, Devices, Removable and Shared. I use Removables because I store my raw images on an external usb ssd since I have only a limited amount of main ssd space.

                          What I found was that if an external update did not update the thumbnail in Manage Mode all I had to do was select a different input folder and then switch back. Photo Studio was forced to re-read the images in the original folder and that caused an update of the thumbnail. If this is still unclear I will be happy to attach some screen shots to show what I mean.

                          Comment


                          • #14
                            .....I now understand the steps ....unfortunately this does not do anything for my "snail" thumbnails. I tried to move to a number of different folders and then back to the folder containing the pictures with the "snail" thumbnails. But the snails stay. I am sure the app is re-building the display, as it takes about two minutes for the thumbnails to appear after I switch back to the folder with the pix. (Note: my folder in question contains 977 images in size between 1MB and 92MB). But as I said, the thumbnails do not change.

                            Comment


                            • #15
                              I have no real idea what is going on on your system, but I assume the "snail" icon means that the software can not understand the layout of the image. I think I know what the software does with a raw image - it extracts the embedded thumbnail from the file and displays it - but I do not know what it does with a jpg. I do not know if there is a thumbnail embedded in a jpg or not. If the original image was raw, then perhaps Snap Heal wrote the thumbnail out badly and it is in error.

                              I do have a couple of suggestions, although I have no way to know if any of them will work. Some of them are more to find the source of the problem rather than to fix it.

                              1. Try loading the "snail" jpg into a pixel editor like Photoshop or Affinity Photo. Make some small change and then save it and see if it still has the same "snail" icon. I have sometimes had problems with a workflow tool understanding an image that was returned by some photo software, and doing that usually fixed the issue. If it does, it means that the problem is probably with Snap Heal.

                              2. Try saving the Snap Heal image in tiff format instead of jpg. See if that fixes the issue.

                              3. Do you have this issue with all of the photos you send to Snap Heal? Or only some? If all, then perhaps there is a problem with Snap Heal understanding the image format so try changing it. Use the Adobe dng converter if the original image was raw. If only some, try loading one of them into a pixel editor and saving it back in the same format to see if that fixes the issue. If so, then it might be that that image is corrupt.

                              4 . Put a copy of one of these images in an accessible location like dropbox and let someone else see if they have the same problem as you are having. If they do not, then the problem is related to something on your machine. If they do, then the problem is either with Snap Heal or Photo Studio.

                              5. Try loading the original image (not the "snail" image) into another MacPhun app like Tonality of Intensify, save it and see if you have the same issue. If you do not, then the problem is in Snap Heal.

                              I am guessing but, since I do not have the same issue as you, I assume it might have something to do with the original image that you sent to Snap Heal and not the returned image. But, as I said, I am guessing.

                              Comment

                              Working...
                              X