Announcement

Collapse
No announcement yet.

41meg Panorama wont display in EDIT Mode but does in view and develop mode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 41meg Panorama wont display in EDIT Mode but does in view and develop mode

    Click image for larger version

Name:	Screenshot 2017-09-07 08.58.03.png
Views:	1
Size:	157.2 KB
ID:	43399 Hi team,

    ​I have been finding some large JPG files ( 41 Meg is size of most recent pic ) that display in View, and Develop Mode, wont display in EDIT Mode.

    ​Any suggestions as to what I can do to fix this ??

    ​In the shot below, you can see the thumbnail in the bottom right, and a blank edit screen..
    Last edited by Mrstewy; 09-06-2017, 03:37 PM.

  • #2
    Click image for larger version

Name:	Screenshot 2017-09-07 09.10.32.png
Views:	1
Size:	2.07 MB
ID:	43398 This is the pic in View Mode - it appears the same in Develop Mode, but wont display in Edit Mode?????

    Comment


    • #3
      I don't have an answer, but there are a couple things I have noticed
      ​* If an image doesn't display in Edit, Duplicate the layer... you will see the image on the duplicated layer
      ​* It is possible there error has to do with the TIF Alpha channel or..
      ​* it may be have something todo with images that have an irregular shape

      ​I am still trying to figure it out exactly..

      Comment


      • #4
        Gus, the duplicate layer worked ???? thank you - but a strange workaround..

        Comment


        • #5
          Something is strange. I thought it was size for a while, too... But I also have a 1.2G image that opens just fine, while I have some smaller 25M images that fail.

          Comment


          • #6
            thanks Gus.. On 2 occasions, since I have used the Duplicate Layer solution to enable editing, ACDSEE has closed down due to a problem when saving.

            Comment


            • #7
              I've noticed that if any image is larger than something over 16000 pixels along the longest side it will not display or process correctly when trying something like perspective correction then crop.
              If I make a pano the first thing I have to do is resize to max16000 pixels then everything works fine.
              This is a bug that needs fixing. When using the pano technique images quickly becpome bigger than 16000 pixels.

              Comment


              • #8
                Originally posted by Mrstewy View Post
                thanks Gus.. On 2 occasions, since I have used the Duplicate Layer solution to enable editing, ACDSEE has closed down due to a problem when saving.
                ​Sorry... I forgot a step...
                Duplicate the layer... Work on it relative to the duplicated layer....
                ​>>> DELETE The original layer <<<
                Save As

                Comment


                • #9
                  thanks GUS.. The Support Team are onto it.

                  Comment


                  • #10
                    Further testing
                    ​I attempted to resize a pano to 15999 using the Export tool... Ultimate through an error message to stay lower than 15000 wide.
                    So... I tried 15000 wide and the 15000xnnnnn image worked just as Trevor suggested,

                    ​Just tried another 210000 x nnnnn pano...
                    Opened in Edit (Layer1, no image seen)
                    Duplicate layer
                    ​See image on new layer... (Layer2)
                    ​Select layer2... manipulate image (I tried color tweaks, perspective, other)
                    ​Select Layer1... Delete Layer
                    ​Layer2 is now selected,
                    Save As...
                    New image is 210000 x nnnnn

                    As this is so weird, it would not surprise me there would be conditions where the work-around will fail.

                    Weird bug... weird work-around... I agree, 16000 pixels on the longest edge really is not that large of a Pano


                    Comment


                    • #11
                      Team, I have a response from ACDSEE Support - it is a DIRECTX restriction... See below


                      ----------------------------------------------------------------------------------------------------------------------------

                      "Thanks for providing the sample file and I can reproduce the problem with the same issue.

                      It appears this is due to limitation of directX that only supports the width being 16384:
                      https://msdn.microsoft.com/en-us/lib...(v=vs.85).aspx

                      So as workaround, if you resize the file to have the width less than 16384 pixels, you can then edit the image. Hope this helps.

                      I will discuss case with QA and development team and I will update your when I have more information.


                      Comment


                      • #12
                        Mrstewy, thanks for following up with tech support!

                        Interesting that DirectX is being called out by TechSupport. I would think if it was purely DirectX, then the workarounds above would fail. Something is strange here.

                        ​Since DirectX is part of the OS, I wonder if DirectX only impacts CPU based processing, while maybe GPU based processing is called with the workarounds.

                        It also seems strange other tools do not have the same limitation. For example, Windows photo viewer, NIK and Affinity seem to work on these files without issue. This might suggest it is not purely DirectX.

                        ​Please, keep us informed.


                        Comment


                        • #13
                          I did some further investigation.... The ACDSee directory contains DirectX9 from 2005. I wonder if being stuck in the 2005 DirectX relates to the DirectX problem referenced by tech support?
                          [DirectX 12 was released by 2015 (with Win10). ​Still doesn't explain why the workarounds seem (at least partially) functional.]

                          Comment


                          • #14
                            I have a similar problem.

                            I have a large picture (panorama) 20152x6943, 139.9 MP.
                            In Acdsee Pro (10) (french version), I can edit the picture (in edit mode). No trouble.

                            In Acdsee 2018 (english version), with the same file, the screen remains black (in edit mode). The image is not displayed.

                            Obviously, same computer, etc. It is incomprehensible.

                            Alaric (French)
                            (i7, Ram 32 Go, GC 4 go, SSD)

                            Comment


                            • #15
                              I too have a response from ACDSEE Support. The same than Mrstewy.

                              Ce problème a été reporté. Malheureusement c'est une limitation de la nouvelle version, cela à faire avec l'utilisation de Direct X dans le mode Éditer.
                              Pour le moment, svp, réduisez la taille horizontal à un max de16384 et testez de nouveau...


                              This bug is known; but it is not a problem in Acdsee Pro 10.

                              Alaric (French)

                              Comment

                              Working...
                              X