Announcement

Collapse
No announcement yet.

ACDSee Ultimate 2018 stability

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ACDSee Ultimate 2018 stability

    U2018 continually crashes on my machine displaying a message similar to "ACDSee has encountered a problem and needs to close". It doesn't corrupt the database which is a good thing but it's an annoying drag on productivity and not up to the quality I've come to expect from ACDSee. I've upgraded to every new version since starting with Pro4 and this is the first time I've really run into a serious quality issue.

    It's interesting that it will crash when I'm not even using it. If it's running in the background or I step away from the machine for lunch for example, it will often have crashed when I get back.

    Is anyone else running into stability problems?
    Thanks, John

  • #2
    Hi John - First off, no there aren't any chronic stability problems with this release. That said, there is standard list of crash causes that are specific to each user. If you have a healthy system (no viruses or OS corruption) then, there are five general causes for a crash of ACDSee – particularly if it is an immediate crash.
    1. Corrupt Image(s) in the startup-folder.
    2. The ACDSee program itself is corrupted.
    3. The Database is corrupted.
    4. The ACDSee Registry Keys are corrupted.
    5. Conflict with another program or process.
    In your case, it may make the most sense to uninstall and reinstall Ult-2018 as the first step. Next, I would recommend that you optimize your database. Your DB is a very likely culprit as evidenced by the fact that you get unattended crashes. Post back if you are not able to pin down the cause.
    Last edited by LV_Bill; 01-04-2018, 06:12 PM.

    Comment


    • #3
      I am also having problems with ACDSee Ultimate 2018. The program does not totally crash but it goes very slow when processing images in both edit and develop modes. It can take up to 45 seconds to load the next image. In edit mode the program will just freeze and no matter what I click on with the mouse, it just beeps at me. I have waited for up to 30 minutes, but the program is still unresponsive and no error messages are displayed.

      I have no option but to open windows task manager and shut ACDSee down from there. I also have ACDSee Ultimate 2010 and it does NOT have the same problems.

      I have used a RAW image the made Ultimate 2018 freeze and loaded it fine in Ultimate 2010. Tried the same image in 2018 later and it worked ok.

      I can live with the occasional program freezes but having to wait 45 seconds for a next image to load is unacceptable. In Ultimate 2010 a next image has always loaded in 2-3 seconds.

      Any ideas how to make Ultimate 2018 behave?
      Thanks, John

      Comment


      • #4
        johnmurf - I have a little bit of the same issue where Ult-2018 seems a bit more sluggish in high CPU operations than Ult-10 did. But, it's only a minor difference -- not seriously slow as you describe. In your case, the problem may be related to your graphics card. But first, I would start with the same two suggestions I made above. Reinstall Ult-2018, then optimize your DB. Next, I would send your issue directly to ACD Tech Support. They are the ones that know about specific graphics processors that may have problems with Ult-2018. They also may recognize symptoms of Registry problems. Here's their link:

        https://acdsystems.desk.com/customer/portal/emails/new


        Another issue which may be involved in your issue is a recent upgrade in Windows 10 to support more 3D graphics. Whatever Microsoft did, Ult-2018 suffered in performance vs. Ult-10 due to this change. Following is what I posted for the ACDSee Developers regarding the Win10-1709 update.

        I've been testing by going back and forth between Ult-10 and Ult-2018 with the same image. Specifically, I'm testing mouse performance while dragging crop lines in Develop > Geometry at 150% image magnification. Ult-10 is pretty much unchanged from before the Win10-1709 update. But, Ult-2018 has definitely become slower and sluggish during my tests. It appears to my eye as though Ult-2018 is more affected by background processing during these crop line drags than Ult-10. But, that may just be appearances. Whatever is going on with the new Win10-1709 release and it's new 3D support, Ult-2018 has suffered in performance.
        Last edited by LV_Bill; 01-05-2018, 10:23 AM.

        Comment


        • #5
          Originally posted by LV_Bill View Post
          johnmurf - Reinstall Ult-2018, then optimize your DB. Next, I would send your issue directly to ACD Tech Support. Another issue which may be involved in your issue is a recent upgrade in Windows 10 to support more 3D graphics. Whatever Microsoft did, Ult-2018 suffered in performance vs. Ult-10 due to this change.[/I]
          I have tried tried optimising the database but this has not helped. I will try reinstalling ultimate 2018 shortly and then re-optimise the database.

          I do have the latest upgrade to Win 10 1709 installed, but the problem persisted before the Win 10 upgrade. I would like to point out that the slowness that I suffer is not always present. Sometimes I can spend two hours on editing images without any issue, but sometimes the slowness issue will manifest itself after editing only 3-6 images. Closing the program down and restarting seems to correct the problem. The problem is more common in edit mode but every now and then it will occur in develop mode but when in develop mode it seems to correct itself after editing a couple more images.

          I will do as you suggested and send the issue to ACD Tech Support.

          Thanks for your help, regards John

          Comment


          • #6
            Same problem, constant crash when importing from SD card. I've tried to copy the content of the card to a folder (no involving ACDSee - to see if it is a card error or not) - which completed fine, then importing from that folder results in a crash again. ACDSee Photo Studio Professional 2018 here. Encountered the same with different types of SD cards, written by different cameras. Any thoughts?

            Comment


            • #7
              Originally posted by Caver View Post
              constant crash when importing from SD card. Any thoughts?
              I have not encountered that problem myself. I copy the files from the SD card usually via a card reader or by plugging the SD card into the laptop.
              I place the files both JPG and RAW into a directory and I have ACDSee open up at this folder by default and its always been ok. The files are from Canon cameras and I have used different SD cards and two different cameras. I am using ACDSee Ultimate 2018.

              The other problems that I was experiencing seem to be resolved when I uninstalled ACDSee an downloaded a new copy and installed that.It may be worth trying that. I also have ACDSee 2010 installed and that does not have any problem loading images From SD card.

              If you don't want to uninstall you current version then maybe try downloading a trial version of Ultimate 2018 and see if it will load your images.

              Comment

              Working...
              X