No announcement yet.

Invisible photo

  • Filter
  • Time
  • Show
Clear All
new posts

  • Invisible photo

    Hi all. You all clearly have a lot of knowledge on this program and I am mystified about this issue we are having in our lab. Someone in our lab made a bunch of .cvx files when we were not there. I am now trying to view them, but when opened, there is an empty box where the image should be. You can click on the image and it becomes selected, but the image is blank. I can see the image in the thumbnail and nothing is hidden (eg., I clicked "unhide all" or show hidden). These files were originally opened in Canvas Draw 1, but they are also invisible in Canvas Draw 3. We don't know which version it was made in, if that matters. Additionally, it seems the images were pdfs what were copied and pasted into a .cvx and saved as a .cvx. I am sure this sounds confusing and perhaps I am not giving enough info, but I am really not sure what could be happening, as I think the files would contain everything and not have to call to something else to get the image to show. I looked through all the titles of topics in this forum and it seems this issue (I don't even know if this is an issue) hasn't come up. There was one topic regarding pictures disappearing after cropping, but there is definitely something there, just invisible. The image was apparently grouped from two at some point, as I can ungroup it. Please let me know if I can make this issue I am having more clear. Would appreciate assistance in any way!

  • #2
    Besides posting on this forum with other users, you should also contact Canvas support.

    In my opinion it's always good to upgrade to the latest version, which is v5 now, because the Canvas developers are continually fixing and improving Canvas Draw. I tried duplicating your problem, but I can't. When I try copy/paste a PDF, I get text completely out of order, and no images. If I need to work with a PDF in Canvas I either use Place or Open and Canvas will convert it for use.


    • #3
      Thank you for your reply, kohanmike! I will contact Canvas support. Did not realize that was an option. Now that I am at work, I can post some examples. I am actually not really sure how this person created the .cvx files. I am assuming it was a copy and paste, because there is a folder of pdfs that match the folder of .cvx. I also found out today that these were actually created about 2 years ago, so we have no way of asking the person who made them what he did. Nevertheless, here is what is going on. I have a folder of .cvx and I can see the images in thumbnail, as you can see in the first upload. When opened in CD1, 2, or 3, what I see is the second upload - an invisible image. I realize we will have to upgrade to CD5, but I am wondering since the thumbnail is blurry, is the actual image or path to the image corrupted? I will also link to a file so anyone can look at it and hopefully mess around with it. In the meantime I will contact Canvas support, but just wondering at this point if it's even a problem with Canvas or something else.

      link to file:



      • #4
        Depending on the original source, it is possible that there is more than one image at exactly the same location and one of the images is blank. That is something I encountered (long ago) with importing PDFs to Canvas X (for a .cvx file). I suggest making a duplicate of the file and experiment with ungrouping and deleting. Sometimes it is necessary to ungroup more than once.



        • #5
          Nika, in the left photo (the Finder window), there is also an AKB .zip file. I take it that's not the one containing the HighRes images to the .cvx files? Trying to think about how this was done etc.

          BTW I am unable to download the Google drive file, wants me to log in.


          • #6
            I also can't download the file and it doesn't show a preview. You need to allow download, but I don't Google Drive so I can't help. Tim has a good suggestion, I've often had to ungroup PDF imports more than once to get it to separate all the items, and there are definitely solid fill white boxes that on the original where outline only. PDF import has been buggy for a long time. The blurry thumbnails are because there is no .cvx version of Canvas on the computer.


            • #7
              Thank you all for the advice. I made the link open to the public, sorry about that.


              I don't even know if it is going to help, though. I cannot reproduce the behavior either. Hermie, the zip file was just the file of all the cvx files that aren't showing the images. I did go to the other computer that the person stored all their files on, but I couldn't find the original scans. I imagine he scanned them from an actual book, as the book was published in 1978.

              Additionally, I tried to see if ungrouping more would help, but after I ungroup them once, the button grays out and I can't ungroup anymore. I suspect this may be a lost cause, but I totally appreciate the assistance! Hopefully Canvas support will having some info.
              Last edited by nika; 08-23-2018, 09:21 AM.


              • #8
                I downloaded the file and ungrouped, but there are only two items in the center, an invisible large box that will not take lines or color and a tall rectangular white box that will take color and outlines, so I moved them to the side and did this screen shot. maybe ACD support can do something.

                Click image for larger version

Name:	Screen Shot 2018-08-23 at 1.27 PM.png
Views:	1
Size:	11.0 KB
ID:	46983


                • #9
                  The larger of the two objects appears to be a Windows EMF (enhanced metafile) object which may have been copied from another program and pasted into Canvas. It appears the same on both Canvas Draw (Mac) and Canvas X 2017 (Windows). I don't know whether it will be possible to recover the content without access to the original file/program.


                  • #10
                    Weird, when I did a Verify File CD5 said there are 5 objects. But I can only find 4. BTW with a file size from under 200 k there really can't be much in it.


                    • #11
                      The CVX file caused Canvas Draw 5 to crash after a while (and some work on it). However, it opens fine in Canvas X (9.02 running on OSX Leopard Server as a VPM in Parallels) and shows the two text objects, a PICT image, and a white rectangle that covers up a scalebar on the PICT image. I can save the PICT image as a PICT and I can render it as a TIFF and save that (JPEG thumbnail attached). Since you have a bunch of them, this may be the best way to access them.
                      Attached Files


                      • #12
                        That should have been "Canvas X (9.02 running on OSX Snow Leopard Server as a VPM in Parallels)" - ie, Snow Leopard, not Leopard.