No announcement yet.

Migrating from PS5 to PS6

  • Filter
  • Time
  • Show
Clear All
new posts

  • Migrating from PS5 to PS6

    I?m having major issues trying to get Photo Studio 6 to work. Upon first attempt some weeks ago after installing PS6, I was able to open (or migrate?) my database that was from PS5. I don?t recall what steps I took ? I presume there was a prompt upon launching the program, offering to migrate or convert the database file over. However, not all keyword categories imported over, nor did keywords themselves that were assigned to any of my images. I called a customer support rep who told me to first ?catalog? the database ? which I did. It didn?t work.

    I tried uninstalling PS6. I just reinstalled it, and when I open the program again, there are no prompts for a license key, nor to migrate anything over. When I try to open my PS5 database file, I get the following error:

    Click image for larger version

Name:	Screen Shot 2019-11-26 at 5.16.09 PM.png
Views:	165
Size:	81.7 KB
ID:	50823

    How do I get PS6 to successfully import my PS5 database ? and all associated metadata ? into the program?
    Attached Files

  • #2
    Hi nicholtl,

    Please try the Tools > Restore Database command, available in the app menu bar.

    Best regards,


    • #3
      I had a different experience: After installing PS6 I too was unsure if the database had been transferred properly, but I went ahead using PS6 with no immediate glitches. Today, however, while consolidating some old files, I found when trying to move some from one folder to another, the message came up that the file could not be located. The only active option in the window was to "save" but when I did that the files in question vanished. I was able to transfer the files using the Finder window. At least some of the files showed a circle with a diagonal line through it, as if to say, "you can't do this". I did not want to test too much at risk of losing important files. I wondered if it was connected to the questionable database migration, so I went in to the Tools/Restore Database command, but I cannot get a window where the "Restore" button is active - it's greyed out. Like nicholti, I tried reinstalling the software in hopes that I would see a new "restore" option or prompt, but the reinstall bypassed everything.


      • #4
        Hi Bruce,

        In the Restore Database window, the Restore button will be greyed out until an ACDSee database is selected.

        The PS5 database is stored at the following location:

        "/Users/<username>/Library/Application Support/ACD Systems/ACDSee Photo Studio 5/Database/com.ACDSystems.ACDSeePhotoStudio5 (version 8.0).mediaDatabase"

        On macOS, this path is hidden by default, but you can use the Finder shortcut cmd+shift+G to access the "Go to Folder" dialog and then paste in the above path (substituting your username).

        Some notes regarding restoring:
        - Please ensure the PS5 database is closed before beginning the Restore operation.
        - Note the Restore operation will replace your current PS6 database with the PS5 database you restore. It will not merge the PS5 database into the current PS6 database.
        - If you prefer, you can back up your database in PS5 (via Tools > Back Up Database...), and then restore from the backup.



        • #5
          David - thanks for the detailed (and complicated) explanation. Maybe I should back up and try to go through the "best-practice" upgrade procedure, and see if the database is managed as it should be that way. How should one uninstall version 6 effectively so that it can be reinstalled as if it were a new upgrade, to see if the database is kept viable in the new version? If all users have to go through the process you have described, it's a less than seamless upgrade . . .


          • #6
            I had the same problem as the OP when upgrading to PS6. During the upgrade I migrated the database and found some keywords missing. The bigger problem though was that as soon as I tried a filtered view in the Manage window, the program crashed. Every attempt to restart also crashed.
            A call to tech support provided the below instructions to completely uninstall the program.
            After uninstalling and reinstalling, this time doing a database restore instead of migration, the keywords were again missing. Again, applying a filter in the Manage window resulted in a crash. And the program again crashed every time I tried to start it. I've had an email request for support for a couple of days but no response yet. We'll see what they say. For now I'm having to run PS5.

            Uninstall instructions from support (note that all files/directories were not located where indicated in the instructions):

            As always, make sure you have an up to date backup, of your images and your database before deleting these libraries.I suggest that you can try the following to do a complete installation of the ACDSee and see if the issue can be addressed

            In Finder's menu bar, click Go and choose "Go to Folder". Type '~/Library'.

            - Navigate to "~/Library/Application Support/ACD Systems"

            delete "ACDSee"

            - Navigate to "~/Library/Preferences"

            delete "com.ACDSystems.ACDSeePhotoStudio.plist"

            - Navigate to "~/Library/Caches"

            delete "com.ACDSystems.ACDSeePhotoStudio"

            Step 3: Remove the ACDSee configuration stored on the system Library

            - In the Finder, click Go and then click Computer

            - Open your hard drive, for example, Macintosh HD

            - Navigate to "/Library/Application Support/ACD Systems"

            delete "ACDSee"

            Step 4: Reinstall ACDSee Photo Studio for Mac 6

            And you can find the download links of ACD Programs from the following KB article:



            • #7
              Hi Bruce,

              Apologies if my suggestion was too excessive.
              I think the simplest solution for your case is what I suggested at the end: you can back up your database in PS5 (via Tools > Back Up Database...), and then restore from the backup in PS6



              • #8
                FWIW - I worked around the keyword issue by going in PS5, creating categories and adding the files with the keywords that weren't importing, then deleting those keywords and backing up the database. After restoring the database in PS6 I reversed the procedure.
                Not sure why specific keywords could not be restored. I made sure there were no special characters, long names, etc - made no difference.

                As to crashes - best I can tell it was caused by PS6 defaulting to exclude removable devices from the database. After installing this time I unchecked that before applying a filter and it no longer crashes. Or maybe it was whatever was hosing the keyword restore.


                • #9
                  Hey all,

                  So I received a response from customer support over email, and here was the solution, which I'm quoting verbatim (and which worked):

                  1) In the previous version of ACDSee (Mac 5), click Tools | Embed ACDSee Metadata in Selected files and make sure that your are satisfied with your database in Mac 5.

                  2) Close the previous version of ACDSee and start the current version (Mac 6)

                  3) Click Tools | Catalog Folders.


                  That's it. That all it took. I had to go through each folder one-by-one, select all (photos), and then click Tools > Embed ACDSee Metadata in Selected Files. I unchecked the option to create sidecar files, since all my photos are .jpg, .png or .tiff. Presumably, that embedded all assigned keywords into each and every photo, which I repeated across all my subfolders.

                  Then, I closed PS5 and opened PS6. I clicked Tools > Catalog Folders, selected all the subfolders that I had done the embeds to, hit enter, and everything populated properly.