Announcement

Collapse
No announcement yet.

No connection between database and pictures?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No connection between database and pictures?

    Suddenly no possibility of showing in V6 a picture in the finder or turning pics left or right or to open with, and so on.
    It is all grey and not available.

    In "extra" menu from the top (German Version V6) I can send a picture to the extern editor (Affinity),
    then I can save the work in Affinity and then I can see the result (e.g. a red Line) in V6 in the thumbnail.

    The pictures are on a external harddrive.
    There was no problem with the around 33.000 pics since the upgrade last week.

    The database is on the mac,
    pictures stored on the mac had not the above problems.

    ?

    Thanks for help,
    sorry for my englisch

  • #2
    V6 is extremely flaky with external storage.

    In addition to the problem you mentioned - options such as Show in Finder, Reveal in Folder Tree, Open With, etc might gray out. Or opening a specific picture in Develop mode and it might default to the first picture in the folder.

    For the problem you specifically mentioned I created a new folder and then (via ACDSee) moved the files to the new folder. That fixed it for me as well as the other issues with other grayed out options and the problem with Develop mode.

    At least until the next time...

    Comment


    • #3
      Thanks yatyas, how you wrote: it is gray out. In the EXIF datas I can see the correkt storing place of each picture on the external storage.
      No other database on my mac had or has such problems, neither Aperture, nor Lightroom 5 nor Capture One 10 and so on. I think, here is a challenge for the next update?

      My first ACDSee I had end of the 90s on a windows machine. I think around 2010 it was available for the mac. And V6 was in the first days a very, very nice programm....

      Comment


      • #4
        Don't really know what to tell ya. ACDSee on Mac has never been a...reliable or strong application. On Windows I absolutely loved it, on Mac I'm always looking for an alternative.

        Even the workaround I mentioned above is not 100%. It just a flaky app on Mac and does weird crap - specifically with external storage.

        As an example - my folder structure is year>month>raw/jpg. So one case would be 2009>01-January>RAW. In the folder for January 2009 I create a new folder for raw files called DNG. Copy the files from RAW to DNG and everything works. But do the same for 2010 and it doesn't fix the problem.
        BUT - I then create a new folder under 2010 call January ( as opposed to 01-January) and create a sub folder called RAW, copy the files there and everything works.
        Copy them back and it no longer works.
        eta - I've only seen the problem with raw files. jpg seems to be fine.
        eta2 - just deleted the entire 01-January then recreated it. After that everything works. I tried deleting/recreating the year level directory and it doesn't help.

        Best advice I can give is stay on V5.
        Last edited by yatyas; 12-17-2019, 09:03 PM.

        Comment


        • #5
          Hi womfromhome and yatyas,

          Thank you for the feedback.

          I confirm the issues you mention occur in V6 if the non-local volume (e.g. the external drive) is not connected to the machine when you convert your database. This issue has been logged in our internal bug tracking system and is scheduled to be fixed in our next update. In the meantime, I can suggest the following workaround for your consideration:

          NOTE: These steps will replace your current V6 database with the V5 database. If you would prefer to keep your current v6 database, please do not perform this workaround.

          1) In V5, back up your database (via Tools > Back Up Database).
          2) With the external drive connected to your machine, in V6, restore the back up (via Tools > Restore Database).

          Regards,
          David

          Comment


          • #6
            David - thanks for the suggestion (and confirmation that a bug has been identified).

            Couple of points:
            The external drive was connected when I first tried to convert from V5 to V6.
            The problem still occurred after a complete uninstall/reinstall and then a restore as opposed to conversion (external drive was again attached).
            The problem still occurs after (another) uninstall/reinstall and then a catalog (embedded metadata) of folders, instead of conversion/restore (external drive obviously attached for this).

            Thanks again

            Comment


            • #7
              Hello David,
              thanks for the quick reply.

              The error only occurred to me when I booted up the computer,
              started ACDSee and forgot to switch on the external hard drive as well.

              Thank you for your advice to repair the database.

              Here are my questions
              1.) can't I take an older Time Machine copy of the V6 database before the problems?
              2.) Can I not use the backup of the V6 database when the error has not yet occurred?

              I am a extreme backup user,
              I have my experience there,
              so I made a backup right after converting from V5 to V6
              and after the first works in V6.

              At the moment I have dragged the photos from the past 3 years
              onto the internal hard drive and created a new database there.
              It remains exciting.

              Thanks again,
              Wolfgang

              Comment


              • #8
                Hi womfromhome,

                I believe the cause of the issue is a bug in the database conversion process in the case where the non-local volume is disconnected (as mentioned in my above post).
                Therefore I think any backups of the V6 database created after the database conversion will also have the issue.
                If possible, I recommend restoring a backup of the V5 database with the non-local volumes connected. However, as mentioned, I recognize this may not be ideal since restoring a backup replaces the current V6 database (meaning any work you have done in V6 would be lost).

                Please let me know if I can assist further.

                Regards,
                David

                Comment


                • #9
                  Hi David,

                  Thanks for your help,
                  perhaps it is interesting for you, that the working with 260 GB of pictures on the external volume was in V5 quite comfortable but incredibly fast in V6 (.....the first days....)

                  I hope, you can fix the bug, meanwhile I have the latest 69 GB of pictures on the internal volume with ACDSee and the Rest external for working meanwhile with LR or DxO

                  Regards
                  Wolfgang

                  Comment

                  Working...
                  X