No announcement yet.

Seriously, did you test it ?? Is it still a beta you sold us ?!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Seriously, did you test it ?? Is it still a beta you sold us ?!

    Please try right click - in Photos application - on a picture -> Modify With -> ACDSee Photo Studio 4.0
    Then in ACDSee, right click, Batch -> Resize, 20% -> Run batch...

    It worked once only then I was never been able to do it again with another picture ! It does not stop crashing ....

    Any option to get refunded ? Or bug fixed ?

    Sorry, but I'm just upset, this tools I bought I just CANNOT use it, whatever simple things I want to do, I got stuck ((

    Here some logs which should help you .... (full file available, but rtf rejected by this forum )

    Process: ACDSee Photo Studio [85440]
    Path: /Applications/ACDSee Photo Photo Studio
    Identifier: com.ACDSystems.ACDSeePhotoStudio
    Version: 4.0 (588)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: ACDSee Photo Studio [85440]
    User ID: 502

    Date/Time: 2018-01-15 00:16:32.038 +0900
    OS Version: Mac OS X 10.13.3 (17D29a)
    Report Version: 12
    Anonymous UUID: 60D72A8F-519A-B621-E23E-A3A8304E5F02

    Sleep/Wake UUID: 559FA15F-C651-44FB-9566-6FA6886D15B2

    Time Awake Since Boot: 720000 seconds
    Time Since Wake: 10000 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue:

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [0]

    VM Regions Near 0:
    __TEXT 0000000105332000-0000000105a2c000 [ 7144K] r-x/rwx SM=COW /Applications/ACDSee Photo Photo Studio

    Thread 0 Crashed:: Dispatch queue:
    0 0x00007fff290d558b CFStringGetCString + 43
    1 0x00007fff2a754cfa MDItemCreate + 85
    2 com.ACDSystems.ACDSeePhotoStudio 0x000000010538a9b0 -[BrowsingSelection applyFSCommentOnCreate:] + 1072
    3 com.ACDSystems.ACDSeePhotoStudio 0x000000010538ac31 -[BrowsingSelection onFileOperationCreate:] + 257
    5 0x00007fff2913daaa _CFXRegistrationPost + 442
    6 0x00007fff2913d7f2 ___CFXNotificationPost_block_invoke + 50
    7 0x00007fff290fb670 -[_CFXNotificationRegistrar find: objectbserver:enumerator:] + 1664
    8 0x00007fff290fa7a3 _CFXNotificationPost + 595
    9 0x00007fff2b1df467 -[NSNotificationCenter postNotificationNamebject:userInfo:] + 66
    10 libdispatch.dylib 0x00007fff50a06591 _dispatch_call_block_and_release + 12
    11 libdispatch.dylib 0x00007fff509fed50 _dispatch_client_callout + 8
    12 libdispatch.dylib 0x00007fff50a0a32d _dispatch_main_queue_callback_4CF + 1148
    13 0x00007fff29166929 __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE__ + 9
    14 0x00007fff29128bea __CFRunLoopRun + 2586
    15 0x00007fff29127f43 CFRunLoopRunSpecific + 483
    16 0x00007fff2843fe26 RunCurrentEventLoopInMode + 286
    17 0x00007fff2843fb96 ReceiveNextEventCommon + 613
    18 0x00007fff2843f914 _BlockUntilNextEventMatchingListInModeWithFilter + 64
    19 0x00007fff2670af5f _DPSNextEvent + 2085
    20 0x00007fff26ea0b4c -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:deque ue:] + 3044
    21 0x00007fff266ffd6d -[NSApplication run] + 764
    22 0x00007fff266cef1a NSApplicationMain + 804
    23 libdyld.dylib 0x00007fff50a38115 start + 1


    Model: iMac17,1, BootROM IM171.0147.B00, 4 processors, Intel Core i7, 4 GHz, 24 GB, SMC 2.34f2
    Graphics: AMD Radeon R9 M395X, AMD Radeon R9 M395X, PCIe, 4 GB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533642465238412D52442020
    Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1600 MHz, 0x29E, 0x434D535831364758334D3242313836364331
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533642465238412D52442020
    Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1600 MHz, 0x29E, 0x434D535831364758334D3242313836364331
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x14A), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 6.0.2f2, 3 services, 27 devices, 1 incoming serial ports
    Network Service: Ethernet, Ethernet, en0
    Network Service: iPad, Ethernet, en6
    Network Service: Wi-Fi, AirPort, en1
    Serial ATA Device: APPLE HDD ST2000DM001, 2 TB
    Serial ATA Device: APPLE SSD SM0128G, 121.33 GB
    USB Device: USB 3.0 Bus
    USB Device: USB3.0 Hub
    USB Device: USB Storage
    USB Device: Bluetooth USB Host Controller
    USB Device: FaceTime HD Camera (Built-in)
    USB Device: USB2.0 Hub
    USB Device: iPad
    USB Device: USB-Serial Controller
    Thunderbolt Bus: iMac, Apple Inc., 28.1
    Last edited by AALLeeXX; 01-15-2018, 06:28 AM.

  • #2
    I have tried your scenario, and not had the same results. It works for me.

    So, some questions:

    1) Are you using a raw image? A tiff? A jpg?

    2) Does this happen with every file you try? Or only one? Every type? Or just one?

    4) What OS are you on?

    3) Have you tried it without opening ACDSee through the right-click mechanism? That is, by just opening ACDSee, navigating to the folder, selecting the image and then trying it? It has been my experience with some software (although not this software) the the process works differently when an image is opened one way as compared to another. It should not, but sometimes it does.


    • #3
      Hi, thanks for your feedback.

      1/ In the use case photos are from Photos application, taken with iPhone7, they are in HEIF

      2/ As I wrote, I succeeded once only, all others attempts then failed. I think I kept trying the same file only (I needed that one...). Today, I tried again but this worked at least 3 times in a row ! (in between the mac was in idle mode, ACDSee was closed. it opens on first operation, and was already opened for the following ones).

      3/ I understand the point here, but no, operating from ACDSee directly did not cause any trouble.

      4/ Latest MacOs, as shown in log: OS Version: Mac OS X 10.13.3 (17D29a)

      Somehow, I think there is a lots of randomness in ACDSee now - see also troubles I reported with my NAS, sometimes NOK, sometimes OK.
      Problem is when its wrong, I cannot recover... It seems that hibernating/idling the mac helps... but that should not be a solution

      Also on major feature missing: log export and sending to ACDSee, could be even manually triggered.... Mac Os extract some and they are sent to Apple. This would be more accurate that bug description we can make here.


      • #4
        Nothing in your response gives me any idea what might be the root cause of your issues, but 2 things stick out (and I will try to get the numbering right this time)

        1. Your issue involves images in HEIF format and I do not have any of those to use in testing. I do not have an iPhone 7 and I do not use Photos, so perhaps I could not recreate your problem anyway. I you wanted to send me one or two I could try to recreate your issue, just to see if it is restricted to your machine, but I do not know how much help that would be anyway since I am also on High Sierra.

        2. This problem only occurs when you open ACDSee using the right-click method. That should nor work any differently than opening the software and then using the Open command, but I know from some experience with other software that I also get different behavior when I open an image that way as compared to opening it from within the software.

        None of that is any help to you, I know, and anything I could suggest would only be guesswork on my part. Sorry.


        • #5
          Hi AALLeeXX and miksons,

          Thank you for this report and troubleshooting. AALLeeXX, the log you provided was very helpful and the questions and answers between you and miksons were also very helpful. I have investigated this issue.

          I believe the crash is due to a bug in ACDSee 4.0 where creating a file in a folder whose name contains a "%" symbol will cause a crash.
          This issue will be fixed in ACDSee 4.1.

          I note that when you select an image in the Apple Photos 3.0 app and use the Edit With command, Photos creates a copy of the image in a folder whose name is a long string of "random" characters.
          It seems that in cases where this folder name contains the % symbol, the crash will occur.

          AALLeeXX, can you please confirm if these findings match your experience? On my system, I found the folder is located here:

          ~/Pictures/Photos Library.photoslibrary/private/

          Best regards,


          • #6
            Hi Miksons,

            No problem at all, dont be sorry
            But indeed if conditions in 1/ are so different, you have no chance to get the same troubles - lucky guy About 2, I'm not sure whether this is a simple right click like in finder. Photos looks far more complicated with its database mgt...
            Anyway, thanks a lot fro trying, appreciated a lot !

            Hi David,

            Thanks for your feeadback. I feel you get close to it. I also found the same, that ACDSee creates a working copy of the photo to be modified in the same location as the original, which - with Photos - is located deeply in the photo library, in a path like
            As I wrote above, this is random trouble - do you confirm with your problem too ?
            Here no % sign, but some + and accentuated characters instead.

            Here I did not expect ACDSee to work in that folder which is part of the library as I don't know how it is managed by Photos. I would rather suggest at least prompting User where (s)he wants to clone the working copy of the photo with a default ADCSee working folder (user customizable), the original location (here the library - with a warning for the user) or a freely selectable location.

            Hoping this helps and soon get the 4.1 released

            Thanks, kind regards,


            • #7
              HI AALLeeXX,

              Thank you for your reply.

              I've tried to reproduce the issue with other characters in the folder name, including the + sign and the è, but I was not able to.
              I believe since you are coming from the, the working folder is created and determined by Photos before the image is passed to ACDSee.
              As a workaround, one option may be to create a saved Batch Preset in ACDSee that copies the file to the destination of your choosing. Then you could run that preset at any time (even associating to a custom keyboard shortcut if desired).

              Best regards,