No announcement yet.

Import from iPad does not work with high number of selected files

  • Filter
  • Time
  • Show
Clear All
new posts

  • Import from iPad does not work with high number of selected files

    Trying to imports pic from my iPad. There are 4000+. Destination is a NAS (but I don't think this makes any difference - not tested other destination anyway).
    Feature works fine if selected number of files is pretty low, ie below 200. Above, ACDSee just hangs..............
    Please test it.... It's still unusable (

  • #2
    Hello AALLeeXX,

    I asked the development team about this issue and they reported back:

    Import 2K images from my iPhone 6 plus to local drive and didn't reproduce the hang. I also tried import 2k images from iPhone 6 Plus to NAS which was slow but ACDSee didn’t freeze during this process.

    Can you try importing to a local drive and see if ACDSee hangs?



    • #3
      Hello Mark,

      Just tried, but exactly same behaviour. After the wizard is closed, the pointer keeps turning infinitely (colored wheel), no progress bar is displayed and ACDSee appears as non responding in MacOs "Force to quit" app list.


      • #4
        Hello AALLeeXX,

        Did ACDSee generate a crash report? Crash Reports are available in (in the sidebar, select "User Reports"). Are you running the latest build of ACDSee (see below)? And, what OS are your working on?

        Product support for ACDSee Photo Studio for Mac 4.


        • #5
          Hello Admin,

          Yes there is a crash report, where can I send it ?

          ACDSee is latest made public, 4,2 744

          And OS is current beta of MacOs X:

          Version du système : macOS 10.13.5 (17F70a)
          Version du noyau : Darwin 17.6.0
          Volume de démarrage : Macintosh HD
          Mode de démarrage : Normal
          Nom de l’ordinateur : *************
          Nom de l’utilisateur : **************
          Mémoire virtuelle sécurisée : activée
          Protection de l’intégrité du système : activée
          Temps depuis le démarrage : 2 jours 23:30

          The mac :
          Nom du modèle : iMac
          Identifiant du modèle : iMac17,1
          Nom du processeur : Intel Core i7
          Vitesse du processeur : 4 GHz
          Nombre de processeurs : 1
          Nombre total de cœurs : 4
          Cache de niveau 2 (par cœur) : 256 Ko
          Cache de niveau 3 : 8 Mo
          Mémoire : 24 Go
          Version de la ROM de démarrage : IM171.0154.B00
          Version SMC (système) : 2.34f2
          Numéro de série (système) : *************
          UUID du matériel : ***********************************

          Below an extract of the crash report:

          Process: ACDSee Photo Studio [2110]
          Path: /Applications/ACDSee Photo Photo Studio
          Identifier: com.ACDSystems.ACDSeePhotoStudio
          Version: 4.2 (744)
          Code Type: X86-64 (Native)
          Parent Process: ??? [1]
          Responsible: ACDSee Photo Studio [2110]
          User ID: 502

          Date/Time: 2018-05-20 22:51:03.721 +0900
          OS Version: Mac OS X 10.13.5 (17F66a)
          Report Version: 12
          Anonymous UUID: 60D72A8F-519A-B621-E23E-A3A8304E5F02

          Sleep/Wake UUID: B15B634D-1E30-4B26-99E0-DE8EC6DD9A77

          Time Awake Since Boot: 110000 seconds

          System Integrity Protection: enabled

          Crashed Thread: 0 Dispatch queue:

          Exception Type: EXC_BAD_ACCESS (SIGSEGV)
          Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
          Exception Note: EXC_CORPSE_NOTIFY

          Termination Signal: Segmentation fault: 11
          Termination Reason: Namespace SIGNAL, Code 0xb
          Terminating Process: exc handler [0]

          VM Regions Near 0:
          __TEXT 000000010fe79000-0000000110579000 [ 7168K] r-x/rwx SM=COW /Applications/ACDSee Photo Photo Studio

          Application Specific Information:
          objc_msgSend() selector name: objectForKey:

          Hope this helps....


          • #6
            Hello AALLeeXX,

            We do need the full crash report. Can you send it to Customer Care (see below) and in the ticket write "Attention Mark Cosgrove"?

            When I've received it I'll confirm here.

            Thank you,


            • #7
              Hello Mark,

              Just sent.



              • #8
                Chiming in because it goes to my biggest complaint which is dealing with large numbers of files that the app has never been able to handle well. Mark you tested with 2K files but I'm willing to bet if you went to 4K files like WKR you'll get the same results. The large number of file problem always gets incrementally worse as the number of files grows. This is an issue that cuts across many functions some of which I have pointed out previously but has never been addressed. You can't have an app that limits your usefulness to working with just a few files. 2K files is just a few files. 60-100K files is a photographers library.


                • #9

                  I received the crash report and I'll get development to investigate.

                  I'll report back.

                  Thank you,


                  • #10
                    Hello Mark,

                    Any feedback now ?


                    • #11
                      Hello AALeeXX,

                      Investigating the problem was been assigned to a developer with a due date -- on or before June 29th. I'll update asap.



                      • #12
                        Mark: another example of problems with large numbers of files. This issue sweeps across many functions and goes to the very heart of the architecture. It needs to be solved before another release or this potential great app is limited or useless to us who already have large collections. Many users collections will eventually grow and hit this wall. I've been the lone voice complaining about this problem for years but now others are beginning to complain as well.
                        Last edited by LeChiffre; 06-29-2018, 07:38 PM.


                        • #13
                          Well, seems there is no more follow up :-((


                          • #14
                            Hi AALLeeXX,

                            Please be assured we are actively investigating this issue. At this time, we haven't been able to reproduce the behaviour you describe. May I ask some questions:

                            1) When you import, which "Place in Subfolder" option do you use? Could you provide the exact option ?
                            2) Do you apply any other options? For example, Replace Existing Files, Run Batch Preset, or Rename?
                            3) Can you successfully import the same 4000+ images from your iPad using Image

                            Best regards,


                            • #15
                              Hi AALLeeXX,

                              One more question: in the ACDSee folders pane (on the left side in Manage mode), did you have an iOS device selected at the time of import? In other words, are you browsing an iOS device when you experience this issue?