Announcement

Collapse
No announcement yet.

ACDSee keeps freezing when I try to modify PEF (Pentax RAW) images

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ACDSee keeps freezing when I try to modify PEF (Pentax RAW) images

    I have tried to modify a couple of PEF images (i.e. Pentax RAW format). And in each case ACDSee froze. In each case after I tried to finish the modification (either by stepping on to the next image, or by using the "Done" button) ACDSee stopped responding and I eventually had to "Force Quit" the application.

    Attached image 1 shows the actual image
    Attached image 2 shows the image after I "straightened" it
    Attached image 3 shows the message "Applying changes to 1 item" several minutes after I tried to apply the change
    Attached image 4 shows the Activity Monitor app indicating that ACDSee is not responding

    Note: the attachments are in a special folder on my drop box, as attaching them to this post still does not work. I keep getting an error message which says "UPLOAD: Invalid File 2019-08-09_09-45-41.jpg"
    ....and when I tried to simple "copy and paste" the image, all hell breaks loose.

    So here are the links:
    https://www.dropbox.com/s/mk5apns1uz...45-41.jpg?dl=0
    https://www.dropbox.com/s/ynmofk8abg...46-57.jpg?dl=0
    https://www.dropbox.com/s/erh7sa7pnx...47-42.jpg?dl=0
    https://www.dropbox.com/s/qahursef1q...54-14.jpg?dl=0

  • #2
    Hi Tahunga,

    Thank you for the report. May I ask some questions:

    1) On what macOS version did you experience this issue?
    2) Which Pentax camera are these images from?

    Regards,
    David

    Comment


    • #3
      Hi David,

      1) This issue happened on my iMac running macOS High Sierra Version 10.13.6
      2) The particular picture was taken with a Pentax K20D camera (internal camera software Ver 1.04). Here is the link to the original picture in case you want to use it for your tests. https://www.dropbox.com/s/zrfpw3ee33...P8338.PEF?dl=0

      By the way, I tried some additional things using the exactly same picture and found that:
      1) If I modify the picture using the Develop>Tune functions (such as the General>Vibrance and the Light EQ>Brightening

      Comment


      • #4
        Hi Tahunga,

        Thank you for the additional info and sharing the picture.

        I've spent time testing this further but I'm still not able to reproduce the issue. May I ask some more questions:

        1) What are the specs of your iMac? Is it 4K, 5K? What year is it from?
        2) What graphics card does your iMac have?
        3) When you trigger this issue, are there any warnings or errors logged in Console.app that come from ACDSee?
        4) Other than Straightening, what other adjustments are applied (if any)? Does the issue occur regardless of which adjustment you apply?
        5) You mention you experience this issue with Pentax K20D PEF images. To confirm, does this mean that you do not experience the issue with other filetypes even if you apply the same adjustments?

        Regards,
        David

        Comment


        • #5
          Hi David,

          I was on the road in the middle of no-where (i.e. Canadian National Rocky Mountain Parks), and wifi only happend about once every two week. So sorry for the delay in my response.

          My iMac runs:
          1. macOS High Sierra Version 10.13.6 (which is the latest OS I can load on it).
          2. it is a 27-inch mid 2011 type
          3. Processor 3.4 GHz intel Core i7
          4. Memory = 16 GB 1333 MHz DDR3
          5. Graphics AMD Radeon HD 6970M 2048 MB

          Now that I am back I can run some more tests ..... and would you know it, I can not re-create the problems. So please consider them fixed .... until I can re-create them again.

          Regards

          ....Tahunga

          Comment


          • #6
            David,

            Here are a couple of interesting findings. The links next to my text in the following note take you to the screen images in my dropbox:
            1. Note: The sort order is "Sort by Name" https://www.dropbox.com/s/n4g9noc686gmlyb/Sort%20Order.pdf?dl=0
            2. When I display the folder content (/Volumes/Thunderbolt 4TB/Pix Libraries/Canada/British Columbia/Around CR) with one of the images in question (IMGP8338) that picture is clearly missing, https://www.dropbox.com/s/8vzhzm9h04ufff3/Folder%20Content.pdf?dl=0
            3. When I do a quick search for the picture I get a "No Found" response, https://www.dropbox.com/s/zge5keniu5euvq5/Initial%20QuickSearch.pdf?dl=0
            4. When I shorten the name to IMGP83 I get a few pictures, including the one in question, https://www.dropbox.com/s/g5ebt1ypnu0xgf4/Partial%20QuickSearch.pdf?dl=0
            5. When I then add the last two digits to the quick search to make it IMGP8338 all of a sudden the picture shows up. https://www.dropbox.com/s/8010vwt53l7usts/Second%20Full%20Search.pdf?dl=0

            Note that in the file information under "Located In" the picture is clearly shown in the folder I was looking at, namely /Volumes/Thunderbolt 4TB/Pix Libraries/Canada/British Columbia/Around CR

            ....of course, you may tell me that these issues are fixed in macOS 10.14

            Hope this makes all sense,

            Tahunga

            Comment

            Working...
            X