Announcement

Collapse
No announcement yet.

Spotlight Comments can not be written

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spotlight Comments can not be written

    In the past I have used the Spotlight Comments quite successfully. However, today I encountered an issue which I can not explain:

    I was going to organize all pictures in a given sub-folder. The pictures come in a variety of formats. Namely:
    • .JPG
    • .PNG
    • .PEF
    • .DNG
    As I tried to enter a Spotlight Comment in my first picture I got the message: "Source File not found". But the source file is definitively found by the Finder and a bunch of other Photo Editing apps. Even when I open the pictures from ACDSee using the "External Editor" option the pictures open just fine, and I can modify them and save them back to the picture drive.

    So I verified the following:
    • In Manage mode, I clicked ACDSee Photo Studio 6>Preferences...
    • In the Preferences dialog box, under General, selected the Metadata tab.
    • On the Metadata tab I verified that the "Enable Spotlight Comments" was selected. It was....
    Next I tried one of each of the above mentioned picture formats. All of them gave me the same error message. In fact, I could not find a single picture which did not give me the error message. In short, I could not find a single picture which would allow me to enter a Spotlight Comment.

    So I tried to go to ACDSee Photo Studio 6>Tools>Optimize Database then selected the drive on which all my pictures are (including the sub-folder I tried to organize) and let ACDSee optimize it. But the result is the same. The Spotlight Comments do not work.

    One more observation: Spotlight Comments which I added in the past to pictures located on the same drive, are shown in my current configuration.

    ......I was wondering if the issue is that the drive with all my pictures is an external drive which normally is connected to my iMac. Today I connected it to my MacBook Air (as I often do). ACDSee works fine that way, except to create Spotlight Comments. In the past I have often connected my picture drive to my MacBook Air and all worked well. However, I can't remember if I ever tried to write Spotlight Comments in this configuration.

  • #2
    One more thing regarding this issue: I opened one of the picture in the above mentioned sub-folder using Affinity Photo. I then added a comment, applied a Rating, and changed the name of the picture slightly, all in the File Metadata. Then I saved the image. Next I opened that same picture in ACDSee and looked in the File Metadata. However, ACDSee does not show any of my additions. The comment can be seen in both the EXIF>Description>Image Description and the IPTC Core>Content>Description. But neither the Rating or the changed name can be found anywhere in the Metadata in ACDSee.


    On the other hand, when I go back and open the same picture in Affinity Photo, the comment, rating, and changed name is in the File Metadata. How come?

    Comment


    • #3
      Hi Tahunga,

      Regarding the Spotlight comment, unfortunately, this is a limitation on macOS 10.14 and above. As mentioned in the Release Notes:
      • On macOS 10.14 and 10.15, writing a Spotlight Comment fails with error “Source file not found”.

      Comment


      • #4
        Hi Tahunga,

        Unfortunately, ACDSee Mac's rating does not seem to be compatible with Affinity Photo's rating.
        Regarding name, do you mean the filename or do you mean something else?

        Regards,
        David

        Comment


        • #5
          Hi David,
          The filename I mentioned was not a "real filename". Sorry, my mistake. So please ignore that comment.

          I just did some "serious" Metadata testing on one single picture using both ACDSee (my primary image organizer app) and Affinity Photo (my new, primary photo editing app) and found the following:
          • None of the text I added to the ACDSee Metadata is visible in the Metadata in Affinity. Neither in File Metadata or XMP Metadata. That includes:
            • Caption
            • Author
            • Rating
            • Notes
          • None of the text I added to the ACDSee IPTC Core Metadata is visible in the Affinity Photo IPTC (Image), the IPTC (Contact), or the XMP Metadata. That includes:
            • IPTC Core>Content>Title
            • IPTC Core>Content>Description
          Bottom line: I can't use the Metadata in these two apps together, as they don't seem to work together. I can only use the metadata in one OR the other app (or enter it in both separately). As you said, unfortunately, ACDSee Mac's metadata does not seem to be compatible with Affinity Photo's.

          Comment


          • #6
            Hi Tahunga,

            Thanks for the additional info. Regarding Caption, Author, and Notes, these are ACDSee Metadata and are specific to ACDSee. However IPTC metadata should be compatible with other apps.

            You mentioned you added IPTC Title and Description using ACDSee, but that you couldn't see those in Affinity Photo's IPTC (Image), the IPTC (Contact), or the XMP Metadata panel. Do those panels include Title and Description? Perhaps Affinity doesn't display those specific fields in those specific places?

            Regards,
            David

            Comment


            • #7
              Hi David,
              Affinity Photo has a bunch of sub-categories for Meta Data. Namely:
              • File https://www.dropbox.com/s/4snyh6jj352i4et/2020-05-30_14-23-56-File.jpg?dl=0
              • EXIF https://www.dropbox.com/s/7i5egbopzjhr811/2020-05-30_14-23-27-EXIF.jpg?dl=0
              • IPTC (image) https://www.dropbox.com/s/7c0m7d4gnk...ge%29.jpg?dl=0
              • IPTC (Contact) https://www.dropbox.com/s/g7f1ab4im7ej6rn/2020-05-30_14-25-57%20IPTC%20%28Contact%29.jpg?dl=0
              • Rights https://www.dropbox.com/s/p07pvt25zbfwwe8/2020-05-30_14-26-21%20Rights.jpg?dl=0
              • Details https://www.dropbox.com/s/vr7785ap9n5228w/2020-05-30_14-27-30%20Details.jpg?dl=0
              • Raw data https://www.dropbox.com/s/pnlapzsoa6eprde/2020-05-30_14-28-05%20Raw%20data.jpg?dl=0
              Hope this answers your question. Let me know if I can help with some additional tests.

              Cheers,
              ....Tahunga

              Comment

              Working...
              X