No announcement yet.

Impossible to print with Ultimate 9 on Canon printer

  • Filter
  • Time
  • Show
Clear All
new posts

  • Impossible to print with Ultimate 9 on Canon printer

    I have a very frustrating and annoying problem with Ultimate 9 printing on Canon WG7550 printer. The problem is not 100% systematic but I haven't been able to correlate it with printer settings.

    The phenomenon is the following: the printer starts normally but after a few cm of printing the page is ejected and the printing of the same image is starting all over again with the same problem. I have to cancel the printing to stop trashing photo paper sheets. This is true on any format. I have tried printing the same image using the Canon printing utility and it works. So this does not seems to be printer related. I have tried to switch the interface from Ethernet to USB but no difference.
    I have noticed that when I enter the print screen from the menu "Print Image", it is displayed that there 2 pages to print. This seems strange, why 2 pages for a single image ?

    In any case, since several days, I am totally unable to print anything. Can someone help ?

    I attach 1 scan of print with the problem. The size of the printed part is not constant.

    Thank you

  • #2
    My Canon MG68020 prints just fine from ACDSee.

    Is your printer driver up to date?

    What KIND of photo are you trying to print? PSD with layers, *.ACDC, multipage TIF, single page Tif, Jpgs? That sort of thing.

    Also, have you rebooted the computer since this problem has occurred? have you physically turned the Printer off and restarted it?
    Last edited by Glen Barrington; 12-28-2016, 05:43 PM.