Announcement

Collapse
No announcement yet.

How to stop batch rename removing the file extension

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Edvard
    replied
    I use Search and Replace when renaming. To search, I enter a dot (.), To replace I write acd and dot (acd.).

    Leave a comment:


  • FairfieldFogeys
    replied
    Thank you for your answer! I have just started having this problem with file extensions being altered by ACDSee Ultimate 2020. I think I did have two periods in my filename. I can stop tearing my hair out

    Leave a comment:


  • Emil
    replied
    Originally posted by StuartT View Post
    ..You can't have two periods in a filename.
    ???

    Since decades Windows allows more than one dot in filenames. This is an restriction of AC.

    Leave a comment:


  • StuartT
    replied
    But of course! Why didn't I think of that. You can't have two periods in a filename.

    That's it.

    Thanks SO much!

    Leave a comment:


  • popman
    replied
    I agree, this happens to me only, when a period character is within the filename. A warning is issued before the files are renamed. Workaround: insert the extension in the template in this case. E.g. newname##.jpg instead of newname##

    Leave a comment:


  • Tristan H
    replied
    Hi StuartT,

    Is it possible that you have a period character in the template you are using to rename your files? If so, please try removing it and see if that restores the file extension.

    If that doesn't work, could I please get some more information about your system? What OS are you running? Do you have file extensions shown in File Explorer? What version of ACDSee are you running? Does this issue occur regardless of the template you use or other settings in Batch Rename?

    Thanks,
    Tristan H.
    ACD Systems

    Leave a comment:


  • StuartT
    started a topic How to stop batch rename removing the file extension

    How to stop batch rename removing the file extension

    When I do a batch rename operation, I have to manually re-type the file extension. Is there an option somewhere to leave the extension unchanged?
    Thanks
    Last edited by StuartT; 01-13-2020, 03:46 AM.
Working...
X