No announcement yet.

Filter search results

  • Filter
  • Time
  • Show
Clear All
new posts

  • Filter search results

    This screen shot shows a search result in manage mode with filter "without category" enabled and all found items selected (CTRL-A):

    Click image for larger version  Name:	Screenshot.jpg Views:	0 Size:	113.3 KB ID:	55236

    As you can see the list includes items that are indeed assigned to a category.

    How to proof:
    1. Set filter to "all"
    2. Execute a search that returns a view items
    3. Assign the found items to a new (empty) category
    4. Set filter to show "without category". Note: The items will still be displayed
    5. Select the new category. Note: the items will vanish
    6. Execute the search once more. Note: the items will appear again
    -> The filter "without category" doesn't work on search results.

    (I know this is age-old and has been reported before.)
    Last edited by Emil; 02-06-2021, 11:08 AM.

  • #2
    What happen if you run Filter All between each step?

    Update: ok, I tried two different things First I assign / un-assign category on files in a folder, filter on "uncategorized" and it works no matter what. Then I tried to do the same on the files from a search result that selected the same files from the same folder, and it doesn't work. It would appear to be a bug as far as I can tell, I'd report it.
    Last edited by Regor250; 02-06-2021, 08:16 PM.


    • #3
      I find filters very hit and miss.
      Try this test. Go to folders and select the top of a nested foder tree
      Press F3 (search) and just slick start to select all images.
      Now see if any filter works? None of them do for me at all (tagged, Ratings, Labels)


      • #4
        Yepp, the filter doesn't work with search results at all. If this is on purpose, it shouldn't show the head line "Filtern nach ..." .

        BTW. This is just another very old one. AC Pro 8 has it too.


        • #5
          Wow this goes beyond a bug, this is functionality failure and shoud never pass QA testing, so wonder how that happened.
          Now you have confiemed I will stop trying to get it to work lol


          • #6
            Originally posted by MrSteveVee View Post
            Wow this goes beyond a bug, this is functionality failure and shoud never pass QA testing, so wonder how that happened.
            That would depend on whether the development specification called for the Filter function to work in conjunction with the Search Pane function. If it didn't then it is neither a bug, nor a Quality Assurance issue.

            At the moment the Filter seems to work in a somewhat expected manner when used in conjunction with a catalog selection.
            It doesn't appear to work with either the Search Pane function, or the Quick Search function.

            I agree though that It could be more useful if it did,

            Perhaps if ACD Systems are monitoring this thread they could comment on whether there are any plans to change the current arrangement.


            • #7
              If it does not work by design on a search result image subset for whatever reason, then the Filter function should be disabled so one can not attempt to use it and get misleading result, so in that respect it is still a bug.
              Last edited by Regor250; 02-08-2021, 06:38 AM.


              • #8
                Sorry Greyfox I beg to differ, I've been a software developer for over 40 years now (retired), if functionality is given it should work, if it is not applicable for a given scenario it should either be disabled or hidden, it would never have passed QA testing on my watch lol.
                As you say, hopefully an AcDsee guy can chime in and add it to his issues pot.


                • #9
                  If the file list contains shortcut files (*.lnk) the filter "without category" doesn't return any item at all, albeit some of the files aren't assigned to any category.
                  Please ACD Systems don't fix this! You will most likely completely break the (on the whole good) support of shortcut files . . . I have over 2m.

                  I've tried the filter function on several old versions and it seem it never worked as most users would expected at all.