Announcement

Collapse
No announcement yet.

People Mode - Blank Context Thumbnails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • People Mode - Blank Context Thumbnails

    People Mode Thumbnails: Why do I have so many blank (? mark over a face silhouette) context thumbnails (full image)? How to fix it?

    I've been using Ultimate since 2019, but just now started to do people with it using Ultimate 2022. Began with cataloging a new data base and importing face data from Picasa. I'm working with ~ 140k image files, and ~ 700 people, spanning 1968 to 2021).

    Even though I started with the Picasa face data embedded in exifdata, of course I've been having to do tons of tedious manual tweaking of the face to person matching as ACDSee ran it's own face recognition on top of that. I have various comments/questions about annoyances with that process, but for now I'll focus on just this one.

    Specifically: When I toggle from the face thumbnail view to the context thumbnail view, probably 80% or more of the context thumbnails are blank. It seems to be random as to which are good and which are blank. (I don't have any thumbnail issues in Manage mode.)

    Looking in Database view, I see:
    Total Database Size: 3.9 GB
    File Information: 140,528 Image Files
    Thumbnail Information: 1.3 GB Size of ACDSee Thumbnail Cache, 23292 Images with Thumbnails

    Wondering if there's any clues in that information?

    Windows 10 PC, 16 GB memory, 813,364 K allocated to Ultimate 2022 when idling in People Mode.

  • #2
    RAK

    I don't have a definite answer, however I did find early on that I was getting black thumbnails for some faces in People mode, and found that it occurred only with some scanned images. It turn out to only occur when the images were 8 bit grey scale. Once those images were converted to sRGB, they produced the correct face thumbnails in people mode.

    Maybe worth checking whether there is any common factor in regards to image type.

    Comment


    • #3
      I don't think that's it. Virtually all my images are native JPGs. I do notice that there's a higher concentration of blanks for my recent higher res JPGs vs early low-res JPGs, but it's not consistent. I get at least some blanks across my entire spectrum from early film scans to my latest cell camera.

      The blanks are exclusively in my People context view. None in People face view or other modes.

      Wondering if the option of saving thumbnails in the database might help?
      Last edited by RAK; 12-13-2021, 01:15 PM.

      Comment


      • #4
        Do the blank thumbnails have a suggested name recognized? If you can provide one example, we could try to replicate the issue to see if it's the file itself, or some other unrelated issue. Are these files on an external drive?

        Comment


        • #5
          Originally posted by RAK View Post
          ...The blanks are exclusively in my People context view. None in People face view or other modes.
          Just so I'm understanding correctly. In people mode you have the option to show face thumbnails, and all those thumbnails are showing correctly?
          You also have the option to show "source image thumbnails". Is this where the blanks are occurring?

          With the option to show "source image thumbnails" selected, the thumbnails should be showing a thumbnail view of the whole image, and if you select one of these thumbnails, and then click on View, it should open the image proper in view mode. What happens if you select a blank and then click on View?

          Does it show the original image in View, and if so, and if you have the filmstrip showing in View mode (Panes>,Filmstrip ticked) does the thumbnail show in the filmstrip correctly?.

          Having been in view mode, if you then go back to people, and still in "source image thumbnails" mode, click on View>Refresh. Does it then show that particular thumbnail correctly?
          Last edited by Greyfox; 12-13-2021, 06:09 PM.

          Comment


          • #6
            Response to Regor250 02:22 PM:

            All files are on internal drives. When there are suggested names, the corresponding context thumbnails are always good. Problem only occurs for Named and Unnamed faces. In fact there are cases where the same image file appears with a suggested face under Person X with a good context thumbnail AND appears in "Unnamed" with a blank context thumbnail. That definitely argues that it's not a file format problem, rather more likely some sort of application resource problem. Attached (I think) one image file representing the case mentioned above.


            The blank context thumbnails do work. I can select a blank context thumbnail and go to View mode with it where the full image and face box is just as it should be, with name or blank as appropriate and I can edit it.

            The end "experience" is tons of toggling to View and back to People, and every time I do that the People mode view resets to the top and I lose my place in scrolling through (in some cases) a few thousand face thumbnails. (There is no correlation between # of face images per person and the blank problem.)

            Oh how I do wish for a view that paired the face and context thumbnails together!

            Once in awhile going to View with a single face or context thumbnail then back to People seems to result in the blank context thumbnail getting a real image, but not often enough to be really sure of that.

            Am I being clear about face vs context thumbnails? In the upper right bar of the People screen are two small selector icons: Face one is silhouette of head & shoulders, Context one is silhouette of a full body.
            Attached Files
            Last edited by RAK; 12-13-2021, 07:08 PM. Reason: Clarify this as response to Regor250

            Comment


            • #7
              Response to Greyfox 6:56 PM: Yes you understand correctly.

              Taking a blank thumbnail to View mode gets me a correct main image and a correct thumbnail in the filmstrip.
              Going back to People, it still has the blank context thumbnail. View>Refresh doesn't change anything.

              ("Blank thumbnail" = gray face silhouette with white "?" on it)
              Last edited by RAK; 12-13-2021, 07:15 PM. Reason: Added clarification of blank thumbnail

              Comment


              • #8
                I am wondering if this could have anything to do with the Picasa import. Have you tried selecting a bunch of troublesome files, clearing the face data, and running face detection and recognition again on these files? Do they have embedded metadata? What is the source of these files? Do they have anything in common? Did you allow ACDSee Ultimate through your virus check, all sort of funny things happen if you don't (see sticky thread). Note that faces can be viewed grouped (same people all together) and ungrouped.
                Last edited by Regor250; 12-13-2021, 09:03 PM.

                Comment


                • #9
                  It seems that my Picasa imports (with Picasa embedded face data) is the common denominator to the blank context thumbnails in People Mode. About 15% of my images in ACDSee come from my film scanning project that I never put into Picasa and all of those do have good context thumbnails in People mode. By contrast, a spot check of files with imported Picasa data shows none with good context thumbnails in People mode. Origin of all those files is quite varied, so I can't attribute any blame on the original source files.

                  In a few of the Picasa originated files I tried removing faces and redetecting them in ACDSee. In one case I got a good context thumbnail back in People mode, but mostly that didn't work. Even if it did, I sure wouldn't want to go through that for my entire collection.

                  Given that everything else with respect to People / Faces works works apart from the blank context thumbnails, I chalk this up to a "bug / feature" of ACDSee that I can live with, but hope that the developers can take a look under the hood for a fix.

                  ACDSee Commander is whitelisted in my Windows Defender firewall.

                  Comment


                  • #10
                    RAK

                    Is this the type of blank image you are referring to?.

                    Click image for larger version

Name:	Agatha.jpg
Views:	268
Size:	18.5 KB
ID:	58564

                    To get the example above, In view mode, I manually drew the "face box" around the head of the subject and then named it. Doing so created an entry for the person, and the face detection with the name "looks" OK when the image is shown in View mode, but the co-ordinates for the face "box" obviously do not have within them a "proper face", and results in the blank face thumbnail in People mode. If I delete that face and then run face detection on the image it shows as no faces found.

                    It may be that the face co-ordinates from the Picasa images you imported where this occurs for some reason in ACDSee do not contain what ACDSee needs to see it as a proper face. So if you take one of those images and and in View mode run Tools>Face Detection>Remove Faces, the Run Tools>Face Detection>Redetect Faces it should either result in No faces found, or detect the face and either automatically name it, or allow you to name it. And that should then remove the problem from that image.

                    You could run a re-detect on your entire collection, but I would expect that would result in a large amount of work to get all the faces correctly named.
                    The alternative is to perhaps do a few images at a time when you have some spare time.

                    Comment


                    • #11
                      Yes as to the appearance of the blank thumbnail.

                      As to your theory, thanks for the thought but it's doesn't match my situation. First recall from above that my problem is only with the context thumbnail (full image view) in the People mode. Apart from that, the import from Picasa worked just fine in that:
                      1. All my Picasa people were added
                      2. I got all their "head shot" thumbnails correctly (even if Picasa had a few of those off-kilter in position e.g., if Picasa had it on a 'weird' space, ACDSee still registers it as that 'weird' space.)
                      3. I can do all the ACDSee people / face managing on everything, apart from getting actual context thumbnails in People mode. (With corresponding manual workflow impact.)
                      4. I do get accurate full image thumbnails of those same images in Manage and View Mode.
                      5. I've tried the Remove & Redetect as well as Remove and Manual add without it fixing the problem.
                      I've been thinking about rebuilding the database, this time with importing ACDSee face data, since in my theory the Picasa originated faces should now be embedded as ACDSee metadata. (I've done the "Embed" thing.)

                      Ironically, as I tried to start ACDSee just now for the first time today, ACDSee is telling me in effect that my database is toast. Guess I'll get to test my theory.

                      Click image for larger version

Name:	Unable to Connect to Database.jpg
Views:	295
Size:	26.7 KB
ID:	58574

                      Comment


                      • #12
                        FIXED IT. ACDSee built a new database and I then cataloged the Picasa-originated part of my collection using ACDSee face data. No longer have the blank context thumbnails in People mode.

                        Comment


                        • #13
                          I have this exact thing as well (most but not all of the context pictures in people mode) have the question mark face. No Picasa use by me and it is a brand new data base (less than 2 weeks old). I did have the thumbnails at one point, and a few days ago they disappeared. When I go to View mode, the picture is there as the thumbnail i the filmstrip. I did not manually draw any faces. I have not tried redetect yet, but agree it sounds like it would create a lot of work.

                          Comment


                          • #14
                            Originally posted by Scott C View Post
                            I have this exact thing as well (most but not all of the context pictures in people mode) have the question mark face. No Picasa use by me and it is a brand new data base (less than 2 weeks old). I did have the thumbnails at one point, and a few days ago they disappeared. When I go to View mode, the picture is there as the thumbnail i the filmstrip. I did not manually draw any faces. I have not tried redetect yet, but agree it sounds like it would create a lot of work.
                            Select one of the blank (Question mark) faces in people mode, then click on View. That will open the photo in view mode.
                            Have "Show Face Outlines" enabled. You will perhaps then see the Box around the face in the image, with the name

                            If you don't have the Face Detection Pane showing, go to the Panes menu and select Face Detection.
                            You may now see the face thumbnail in the face detection pane.

                            1. Use Tools/Face Detection/Remove Faces to remove the detected faces. You should now see the "Question Marked face" thumbnail in the Face Detection Pane.
                            2. Then use Tools/Face Detection/ReDetect Faces. That should re-detect the faces in that image, and show the thumbnail in the Face Detection Pane.
                            3. Click on Manage Mode which should then show the image thumnail selected
                            4. Right Click, select Metadata/Embed ACDSee metadata.

                            If after doing step 2 above, no faces are detected, then what ever faces are in the image don't meet the criteria for automatic recognition. You can draw the box manually around the face and enter the name. Then continue with steps 3 and 4. M

                            Manually entered faces are not used in auto identification of other faces.

                            If that fixes the problem with that image, then:-

                            If the number of "Question mark" face icons is relatively small, you could opt to carry out the above for each of them.
                            If there are a large number, that probably isn't an attractive option, however I would not jump straight into doing a global rerun recognition.

                            In Tools/Options/Face Detection, the "Rerun Recognition" will remove all previously auto applied face names, and will re-run recognition on those images. It won't change any manually applied names (and hence won't fix this issue if the faces in question were manually done), but will also perhaps result in you having a lot of correction work to do.

                            A method I have used is to select each of the "Question mark" icons, click on view and then tag the image. Repeat until you have all of the images involved tagged.
                            Then in Manage mode, use Catalog pane/ Special items/Tagged to display, then Ctrl+A to select all of the tagged images, then run Tools/:Face Detection/Remove Faces, then Re-Detect faces,

                            There may be a few images where it isn't able to detect faces, so you may need to run them through view mode after, but at least you would only be dealing with the affected ones, not the bulk of the collection.

                            Don't forget to re do the embedding of the ACDSee metadata after removing the Tag
                            Last edited by Greyfox; 02-08-2022, 04:54 PM.

                            Comment


                            • #15
                              I see 100% of the faces in the "Show Face Thumbail" tab, it is the "Show Source Thumbnail" which is missing 90% of the thumbnails. Since we are talking about 100,000 pictures (and some of the faces have "confirmed"faces over 10,000 I will not likely be starting from scratch. If I embed the metadata and then rerun the face detection (from scratch), will it use that metadata when considering faces?

                              BTW, I did try 1-4 above - it did not fix the problem. Interstingly, it took quite a few attempts. When I ran the redetect faces, it was quite good at getting the detection right (and thus it didn't ask me and didn't show back up in the people tab lower frame).
                              Last edited by Scott C; 02-08-2022, 06:32 PM. Reason: Edited to add the second paragraph.

                              Comment

                              Working...
                              X