Announcement

Collapse
No announcement yet.

Some video thumbnails disappear after changing metadata

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some video thumbnails disappear after changing metadata

    Title more or less says it all. For what it's worth, I'm using ACDSee Photo Studio Ultimate 2022 on a Windows 10 PC.

    Background:
    I was trying to better organize my collections, especially those which contain videos. Because ACDSee doesn't seem to understand video creation dates, I tried using the "Adjust Time Stamp" feature to automatically change the "ACDSee Database Date and Time" field to the videos' last-modified date and time.

    Issue:
    I tried changing the date and time on two videos as a test and it was a success! The videos now sorted properly chronologically. However, now they have no thumbnail, just showing a generic VLC icon. Thinking that maybe it was an issue with the "Adjust Time Stamp" feature, I tried manually entering the date and time in the Properties pane for a 3rd video, but that also caused the thumbnail to disappear!

    Now here's where it gets perplexing. This issue isn't reliably reproducible. I tried to reproduce it with some videos I took at a recent bonsai exhibition and one lost its thumbnail while the other 4 had no problem at all. All five videos are the same format (4K, HEVC H.265, .MP4 container), roughly similar size and length (200 MB or so), all taken with the same camera (Pixel 6 Pro). Wondering if it might be a problem with the size of the video (the video with the broken thumbnail was the largest at 250 MB), I just took a 7 minute video on my Pixel which came out to about 3GB in size. I had no problem changing the time stamp and the thumbnail is perfectly fine. There doesn't really seem to be much predictability to when it will happen. The only constant is that it seems to only affect videos taken with the Pixel, but only some of them.

    Attempted Solutions:
    I've tried optimizing the database and using the "Rebuild Thumbnails and Metadata" option under the "Tools > Metadata" menu. Neither of these restore the missing thumbnails. I also tried embedding the metadata, which successfully produced a sidecar file, but still did not restore the missing thumbnails.

    Has anybody else experienced this issue? Is there any solution? It's hard to sift through video data when some of the thumbnails are missing, so I'd appreciate a fix if there is one.

  • #2
    ikanotheokara

    I haven't been able to reproduce that here in ACDSee Ultimate 2022, on Windows 10 Pro 21H2 build 19044.1645, but then I only have a couple of 4K H265 test clips with HEVC format in an MP4 container and they are quite small.

    Can you confirm that you have Microsoft Corporation's HEIF Image Extensions and HEVC Video Extensions from Device Manufacturer installed in your Windows system?

    Using the Adjust Time Stamp function to change the ACDSee Database Date and time to the Last modified date and time, should not be writing to the file itself, only to the database record, and that seems to be confirmed here with no change in the File's CRC32, MD5, or SHA-1 hash values, and no change in the File's Created and Modified dates.

    When the thumbnails don't show in ACDSee correctly after the change to the ACDSee Database Date and time, do they still show correctly in Windows File Explorer?

    Can you post a download link (WeTransfer or similar) to one of the clips that no longer displays the thumbnail in ACDSee? Aside from anything else, that might help to show whether it occurs on more than one installation.

    Comment


    • #3
      Greyfox

      Thank you for taking the time to write such a thorough and thoughtful reply. We are on the same version and build of Windows!

      I do have the necessary image and video extensions installed through the Microsoft Store. Windows Explorer has no trouble showing thumbnails for the affected videos. It seems to just be an issue with ACDSee, as far as I can tell at least.

      I have shared one of the offending videos as an album in OneDrive, so feel free to take a look at it. (Sorry for the heavy breathing and shaky camera, it was just a quick video of a property I might be buying)

      【OneDrive Album】
      https://1drv.ms/u/s!AgYszGOdrFWLhulJ...Vng3w?e=ZCvMaX

      That said, I am beginning to think it's just a random glitch. On a whim I just now tried using the batch rename feature to rename one of the other affected videos, and, its thumbnails returned! I wonder if changing the name forced ACDSee to refresh the entry for that file and rebuild the thumbnails? Either way, it's a viable workaround, although it still doesn't explain why the thumbnails disappeared to begin with. For now, I won't rename or otherwise mess with the video I linked to above, just in case you still want to take a look and see if you can replicate the glitch.

      Comment


      • #4
        ikanotheokara


        I downloaded the zip file, unzipped it and then in U2022 used Batch\Adjust timestamp to set the Database Date to the file's last modified date and time.
        The thumbnail showed correctly.

        I've since tried copying the original file in Windows File Explorer to several different locations on local drives, then browsed to each one in U2022, and repeated the Adjust time stamp. Again the thumbnails all showed correctly, both before the Adjust time stamp and after.

        So with multiple copies of the file here on local drives, I can't reproduce the problem.

        From your first post though, this has occurred with more than just this one file, which suggests it is perhaps not all that random.
        If you are working with files that are on OneDrive, I wonder whether that becomes a factor. I don't use OneDrive, or any cloud storage so I can't explore that avenue.

        Click image for larger version

Name:	Video thumbnail.jpg
Views:	98
Size:	148.8 KB
ID:	60610

        Comment


        • #5
          Greyfox

          Thank you for taking a look! Maybe it's just some idiosyncrasy with my computer, or OneDrive is somehow interfering. (All of my videos and photos are stored locally, but in a folder synced to OneDrive)

          If it continues happening I'll try to keep a close eye on what I'm doing at the time it happens, just in case I uncover a pattern.

          Thanks again for your help! If it weren't for your reply I might not have tried the batch rename process which ended up at least restoring the thumbnails for me!

          Cheers!

          Comment

          Working...
          X