No announcement yet.

Failed with error 21... Anyone?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed with error 21... Anyone?

    I can't make any use of Video Recorder at all.
    As I launch it i get the "failer with error 21" message. I then close the warning window and the software seems to work properly, it lets me set all the settings and start a video recording session. Problem is, it does not really save any file at the end of it.
    I choose the location and filename, hit the save button, but then there is no file anyway.

    Please help me, I have been experiencing this since I installed the software and I can't make any use of it! Please!

  • #2
    Hi Giovanni,

    Sorry to hear you are having trouble using our software.
    I remember you are on a Surface Pro 4 with a 1080p external monitor connected to it. Can you please provide more information about the active webcam or microphone you are using for the video recording session?

    ACD Systems


    • #3
      Thanks for your reply.
      I don't have any webcam or microphone connected, just the internal ones on the Surface Pro 4.


      • #4
        I have news!
        Seems like it's working now.
        I disconnected the Surface HUB (which lets me connect external monitors and usb drives) and tried to start Video Recorder. I got a different kind of error message, asking me to change the Temporary Storage Folder from Tools-Options. I don't know how, but it was set on D:\something but I don't have any drive called D.
        Anyway, I changed the temporary storage folder to C:\ and now it works!!!
        I reconnected the Surface HUB and it still works even on the external monitor.

        One strange thing happened though: I lost all of my files on the desktop. The folders within the desktop folder are still there with their content, but I've lost the spare files and the links I had on the desktop. I don't know how and if this is related to Video Recorder.

        Anyway, the software is working now so the problem seems solved. I will update this message in the next days.